XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X5 Forums > General BMW X5 (E70) and X5M Forum (2006-2013)

Post Reply
 
Thread Tools Search this Thread
      12-02-2019, 11:27 PM   #1
Lviv777
Private First Class
15
Rep
194
Posts

Drives: 11 X5, 01 525i
Join Date: Oct 2017
Location: Calfiornia

iTrader: (0)

Shifter not going into M/S

Noticed today that the shifter wouldn't go into sport mode. Ive tried looking things up but most of the results are for the older manual shifter not the new electronic one. Anyone know solutions to fix this? P,R,N,D all work and shift great just the shifter doesn't go into M/S.
Appreciate 0
      12-03-2019, 01:38 AM   #2
sunny_j
First Lieutenant
sunny_j's Avatar
116
Rep
361
Posts

Drives: 2012 X5d
Join Date: May 2012
Location: Vancouver, British Columbia

iTrader: (0)

there's a tab in the shifter to move over to sport or manual. my guess is that broke. you can open the shifter up to see if you can glue the broken part back on
__________________
2012 X5d | Deleted & BRR Tuned | DWR TCU Tune | 10.25" Android 8.1 Screen

Build Thread
https://www.xbimmers.com/forums/show....php?t=1529213
Appreciate 0
      12-03-2019, 11:58 AM   #3
heatmizr
Lieutenant
United_States
67
Rep
484
Posts

Drives: E70 X5 50i M-Sport
Join Date: Feb 2015
Location: Charlotte, NC

iTrader: (0)

Search harder! j/k But I know between this forum and 'the other one' I found a couple diff threads and posted in them when I had same issue on my 2012 X5 50 Msport.
Mine was preceded by intermittent clicking (of solenoid?), and M/S mode intermittently not available until it just finally wouldn't allow it at all ever. All other functions worked fine.

My solution was to locate another shifter from same year vehicle in a junkyard in the next state, and have it shipped to me. Replacement is a simple swap, just pay attention to removal of trim components to get it out, don't drop any screws deep into the driveline hump, and swap all the electrical harness plugs correctly. I found a schematic of the trim components needing to be removed (I think on one of those threads) which was very helpful.

OK here you go:
My thread:
https://www.xbimmers.com/forums/show....php?t=1610330
This one has the schematic:
https://www.xbimmers.com/forums/show....php?t=1482128
__________________
heatmizr [Todd]
e70 X5 50i M-Sport "The Boss" Loaded
e90 328i - her reliable DD
e36 M3 - Gone to become a track star

Last edited by heatmizr; 12-03-2019 at 12:05 PM.. Reason: added links
Appreciate 1
Lviv77714.50

      12-03-2019, 04:45 PM   #4
Lviv777
Private First Class
15
Rep
194
Posts

Drives: 11 X5, 01 525i
Join Date: Oct 2017
Location: Calfiornia

iTrader: (0)

Quote:
Originally Posted by heatmizr View Post
Search harder! j/k But I know between this forum and 'the other one' I found a couple diff threads and posted in them when I had same issue on my 2012 X5 50 Msport.
Mine was preceded by intermittent clicking (of solenoid?), and M/S mode intermittently not available until it just finally wouldn't allow it at all ever. All other functions worked fine.

My solution was to locate another shifter from same year vehicle in a junkyard in the next state, and have it shipped to me. Replacement is a simple swap, just pay attention to removal of trim components to get it out, don't drop any screws deep into the driveline hump, and swap all the electrical harness plugs correctly. I found a schematic of the trim components needing to be removed (I think on one of those threads) which was very helpful.

OK here you go:
My thread:
https://www.xbimmers.com/forums/show....php?t=1610330
This one has the schematic:
https://www.xbimmers.com/forums/show....php?t=1482128
Thank you very much! Greatly appreciated!
Appreciate 0
      12-19-2019, 03:25 PM   #5
heatmizr
Lieutenant
United_States
67
Rep
484
Posts

Drives: E70 X5 50i M-Sport
Join Date: Feb 2015
Location: Charlotte, NC

iTrader: (0)

Did you replace it? How did it go?
__________________
heatmizr [Todd]
e70 X5 50i M-Sport "The Boss" Loaded
e90 328i - her reliable DD
e36 M3 - Gone to become a track star
Appreciate 0
      12-20-2019, 11:52 AM   #6
Lviv777
Private First Class
15
Rep
194
Posts

Drives: 11 X5, 01 525i
Join Date: Oct 2017
Location: Calfiornia

iTrader: (0)

Quote:
Originally Posted by heatmizr View Post
Did you replace it? How did it go?
Occasionally it works, every time I drive I try it, and once in a while it goes into sport, but usually I'm locked out. Haven't had time to diagnose it yet, but two codes are coming up from my obd scanner, but they are minor ones. Probably going to check it out next week.
Appreciate 0
      12-23-2019, 09:14 PM   #7
Lviv777
Private First Class
15
Rep
194
Posts

Drives: 11 X5, 01 525i
Join Date: Oct 2017
Location: Calfiornia

iTrader: (0)

Get two codes for this issue. CF32 for transmission and A82E for gear selector switch. I assume A82E is the one causing the issue as the transmission isn't directly connected to the shifter. Going to do more diagnostic work on this later. If anyone has more insight on the details please let me know.
Appreciate 0
      12-28-2019, 07:16 PM   #8
Lviv777
Private First Class
15
Rep
194
Posts

Drives: 11 X5, 01 525i
Join Date: Oct 2017
Location: Calfiornia

iTrader: (0)

Update: Took the center console apart. There was nothing stuck or blocking the shifter. Disassembled everything until I had the shifter separated and still didn't see anything wrong. I'm guessing the issue is inside the sealed unit.
Update 2rove the car, parked it heard a loud click, started it up and it started going into M/S again.
Seems like its either a software issue (I attempted resetting the code) or the mechanism is getting stuck time to time. Will provide more updates if I resolve anything.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:25 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST