XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X5 Forums > X5 Photo/Video/Audio Gallery

Post Reply
 
Thread Tools Search this Thread
      06-15-2021, 12:54 AM   #45
0-60Motorsports
Colonel
0-60Motorsports's Avatar
Bahrain
568
Rep
2,903
Posts

Drives: BMW M3 JB 04 Coupe
Join Date: Aug 2007
Location: Kingdom of Bahrain

iTrader: (1)

Quote:
Originally Posted by XRatedM View Post
Thank you!! It's stage 2 and shoots flames!
Awesome! Mine is VFE Stage 2 and probably no flames but i Did ask them to keep it like that and tune it for 92aki and extreme heat. I dont mind going a bit conservative on the tune.
__________________
Current Mods:
2004 E46 M3cs JB/CSL
2010 E70 X5M AW/BLACK
2011 VW Golf R DSG White/Black
IG: @060Motorsports
Appreciate 1
XRatedM30.00
      06-16-2021, 09:29 PM   #46
XRatedM
Private
XRatedM's Avatar
United_States
30
Rep
76
Posts

Drives: 03' 330i - 11' X5M
Join Date: Dec 2020
Location: Northern VA

iTrader: (0)

I was able to take out some time today to flush brake fluid. Long process, mostly because rear lugs were overtightened and they were PIA to remove.

Jacked up the truck and removed all wheels.

Name:  20210616_194828.jpg
Views: 96
Size:  310.7 KB

Removed the cover to gain access to brake fluid reservoir

Name:  20210613_092231.jpg
Views: 99
Size:  391.1 KB

Used Liqui Moly DOT4 brake fluid - I did not flush the ABS system. Ended up only using one bottle of brake fluid (500ml)

Name:  20210613_103621.jpg
Views: 99
Size:  429.7 KB

Used a smaller brake bleeding/flushing tool by Schwaben. Filled up the bottle with 500ml and pressurized the system to about 13psi. Started with passenger rear, driver rear, passenger front outer then inner, driver front outer then inner, bled the system until I saw clear fluid come through.

Name:  20210616_200146.jpg
Views: 101
Size:  455.9 KB

Fluid started off with clear green and turned darker as it kept going. Ended up with what I have in the container.

Name:  20210616_203821.jpg
Views: 97
Size:  135.9 KB

Name:  20210616_212409.jpg
Views: 100
Size:  110.2 KB

Prior to flushing the system, brake pedal was really spongy and did not have the initial bite - had to literally stand on the pedal to make it stop. After the flush, pedal feels much lighter and has the initial bite and bites hard as you press harder - gladly turned out as I expected.

While I was at it, I had 'M' emblems for the wheels sitting around that I decided to put on as well.

Name:  20210616_095349.jpg
Views: 101
Size:  134.0 KB

Name:  20210616_213344.jpg
Views: 99
Size:  190.1 KB
Appreciate 1
      06-22-2021, 07:21 AM   #47
XRatedM
Private
XRatedM's Avatar
United_States
30
Rep
76
Posts

Drives: 03' 330i - 11' X5M
Join Date: Dec 2020
Location: Northern VA

iTrader: (0)

After the purchase, I got a post-purchase inspection done (although I had expected it to be much more detailed but it was very high-level) and one of the things reported bad were Front Thrust Arms.

Front suspension has had a clunk noise since day one and it's probably caused by one of the three; Front Thrust Arms, Lower Control Arm or Upper Control Arm. Since it was mentioned in the inspection, I wanted to replace these first - I had also bought sway bar end links but I didn't have a 18mm spanner, so skipped it for now. Lol

Name:  20210618_191557.jpg
Views: 77
Size:  307.5 KB

FL

Name:  20210618_192856.jpg
Views: 74
Size:  344.5 KB

FR

Name:  20210618_192905.jpg
Views: 78
Size:  335.7 KB

FR

Name:  20210618_192921.jpg
Views: 73
Size:  301.5 KB

FL removed

Name:  20210618_201501.jpg
Views: 74
Size:  246.1 KB

Name:  20210618_201511.jpg
Views: 73
Size:  250.7 KB

FR

Name:  20210618_215203.jpg
Views: 75
Size:  354.4 KB

FL

Name:  20210618_215212.jpg
Views: 74
Size:  391.1 KB

Name:  20210618_215233.jpg
Views: 75
Size:  311.4 KB

Service manual calls for replacing all bolts and nuts. They are self locking.

Name:  20210619_110716.jpg
Views: 73
Size:  799.3 KB

18mm bolt on the bushing side was torqued down to 100nm + 90 degrees.
27mm ball joint bolt was torqued down to 80nm.

Last edited by XRatedM; 06-22-2021 at 07:30 AM..
Appreciate 0
      06-27-2021, 12:18 PM   #48
argento
Lieutenant
argento's Avatar
260
Rep
537
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

Looking good! Did this solve your clunk noise?
__________________
Appreciate 0
      06-28-2021, 09:40 AM   #49
XRatedM
Private
XRatedM's Avatar
United_States
30
Rep
76
Posts

Drives: 03' 330i - 11' X5M
Join Date: Dec 2020
Location: Northern VA

iTrader: (0)

Quote:
Originally Posted by argento View Post
Looking good! Did this solve your clunk noise?
It actually didn't, and I'm suspecting it to be the strut mouths. Not sure if X5M have similar bump stop and other components like X5 that deteriorate over time. I'll do some more digging and replace those and I plan on doing a suspension refresh for front and rear to tighten up the ride.

Your truck has low miles but if you know of any pain/failure points in general, please do share with me.

My truck slightly smokes on idle, oil level is correct, no major drops as such - not sure what may be causing it. I'm certain it's not the valve stem seals, because there's no smoke at cold start, no huge puff after long idle, but it does smoke when you revved. I inspected CCV components and everything looks fine (I replaced the entire CCV system including oil separators) - So i'm looking towards turbo oil return lines (saw a lot of gunk with endoscope, mostly because of turbo coolant line leaks). I did see some oil in turbo compressor housing, heat exchangers, boost solenoids, etc. so I'm guessing it's either the turbos or it's oil return lines.
Appreciate 0
      06-28-2021, 09:56 AM   #50
argento
Lieutenant
argento's Avatar
260
Rep
537
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

Sorry, the only clunk I had was in the rear and it was just a loose sway bar (fasteners out of torque). Does it clunk at constant speed or variable? Does it clunk when you turn? Maybe others will have suggestions...
__________________
Appreciate 0
      07-03-2021, 06:08 PM   #51
xqizitm
New Member
11
Rep
7
Posts

Drives: E70 X5M
Join Date: Jun 2021
Location: DMV

iTrader: (0)

Subscribed. Just picked my X5M a couple weeks ago and just started my own journal. Also located to Northern VA area.

Last edited by xqizitm; 07-03-2021 at 06:08 PM.. Reason: Added more
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:42 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST