XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      03-12-2019, 10:25 PM   #1
titanle
First Lieutenant
28
Rep
317
Posts

Drives: 2010 X6 Activehybrid
Join Date: Jul 2012
Location: vancouver

iTrader: (0)

Exclamation hybrid failure cause?

So driving home today, luckily I was slowly approaching a red light and the vehicle just completely shuts off and in red it shows "Hybrid System Failure". I sat there for about 15 minutes trying to get it to start but no luck.

After getting it towed home, I try to start it and it fires right up no problems. What could be the cause of this aside from the obvious that the hybrid system failed.

I did notice that when I tested the 2 trunk batteries, the factory one was fine but the one I replaced just under a year ago with an AGM battery was almost dead.

I left the dead battery out of the car for about 30 minutes, then put it back in and again it started right up with no problems.

Could a dead battery cause the hybrid system failure?
Appreciate 0
      03-14-2019, 09:40 PM   #2
titanle
First Lieutenant
28
Rep
317
Posts

Drives: 2010 X6 Activehybrid
Join Date: Jul 2012
Location: vancouver

iTrader: (0)

Anyone?
Appreciate 0
      03-17-2019, 05:19 PM   #3
mrsoandso
Private
mrsoandso's Avatar
6
Rep
59
Posts

Drives: '11 X6M
Join Date: Feb 2018
Location: On Canada

iTrader: (0)

You might wanna try the x5 forum, there's more traffic and the platforms are identical.
Appreciate 0
      03-19-2019, 01:20 PM   #4
yco
ignorance is bliss..
151
Rep
423
Posts

Drives: E71 X6M '10
Join Date: Jan 2018
Location: Istanbul & Kiev

iTrader: (0)

at least i can tell that if the car fires up normally batteries should be ok.. cause they dont work with 12V..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:20 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST