XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      08-19-2021, 01:24 PM   #221
pearlpower
First Lieutenant
94
Rep
331
Posts

Drives: 2013 328i
Join Date: Jan 2018
Location: Beverly Grove

iTrader: (0)

Quote:
Originally Posted by jackflyboy View Post
Thanks a lot. I messaged the seller on Alibaba and he's provided the info.
1314? That is it on my unit. Also, anyone figure out how to clear system cache? Not app cache. My unit gets very laggy over time. Else I need to pull the fuse and reboot. Did not see a reboot in the menu anywhere.
Appreciate 0
      08-20-2021, 04:26 AM   #222
alley007
Registered
alley007's Avatar
United_States
0
Rep
4
Posts

Drives: BMW X6 E71
Join Date: Aug 2021
Location: NY

iTrader: (0)

not trying to mess my car up

I have a 2012 x6 50i that I finally decided to keep, since I received a new engine literally free of cost from BMW. In all my cars I install apple car play aftermarket radios but am a be hesitant to put it in my BMW. Guess I really want it professionally done and with a great apple CarPlay system cuz I really don't want the headaches that come with having to fixing the car all the time.

I live in Westchester County NY any info will be appreciated
Appreciate 0
      08-25-2021, 09:38 AM   #223
argento
Captain
argento's Avatar
383
Rep
696
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

Quote:
Originally Posted by alley007 View Post
I have a 2012 x6 50i that I finally decided to keep, since I received a new engine literally free of cost from BMW. In all my cars I install apple car play aftermarket radios but am a be hesitant to put it in my BMW. Guess I really want it professionally done and with a great apple CarPlay system cuz I really don't want the headaches that come with having to fixing the car all the time.

I live in Westchester County NY any info will be appreciated

The android monitors are great but not perfect. There is some effort required to immerse yourself in the operations and figure out solutions around the quirks. Once you're up to speed, you'll enjoy it more. WRT Carplay and these Android monitors, I would recommend skipping the wireless Carplay option and go with the separate Carplay dongle. I and others get skipping when playing music on wireless Carplay.

For me, any hassle is counterbalanced by the fact I can listen to my lossless music files with cd quality sound via a DAC setup. My normal ops with this monitor include using OEM Bluetooth for Communication/Phone, Android Monitor HOME>Apps>Waze for Navigation, Android Monitor HOME>Default Video Player, Android Monitor HOME>Apps>Movies Anywhere for movies, and Android Monitor HOME>Apps>UAPP for microSD Music Library.
__________________
Appreciate 1
      09-17-2021, 07:20 PM   #224
Konradical6
Private
2
Rep
63
Posts

Drives: E70
Join Date: Jul 2020
Location: New York

iTrader: (0)

Anyone try putting a sim in the unit? I put in my T-Mobile sun and whole bars showed up they were greyed out w no signal
Appreciate 0
      09-27-2021, 03:30 PM   #225
argento
Captain
argento's Avatar
383
Rep
696
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

Quote:
Originally Posted by Jon_G View Post
Hi All -Two questions I'm throwing out to see if anyone has thoughts or answers.

1) Does anyone here have issues with music skipping when streaming from apps like Spotify in their CarPlay experience? This seems to happen for me at random, it works fine for a while, then skips for a while every 10 seconds to 1 minute, and then gets better again with no issue. It impacts music that I'm streaming, or even music that is downloaded within Spotify—which I believe means it's not an internet streaming issue.

2) Has anyone been able to access their climate controls user interfaces (seat heat GUI, air direction, etc) while in the android environment? The 4x4 shop told me unfortunately it's not possible, which is quite frustrating, but I figure I'll poke around to see if anyone has come up with anything.

Thanks for any thoughts.

^Regarding question #2 above...I believe the final answer is NO. I've been coding this week and one of the items I coded was for heat seat distribution menu to appear when I press the heated seat button. While on the android side, pressing the heated seat button, does not switch you back to oem side. However, when you manually switch to the oem side, the menu will be there. It disappears after about 10s, so you'd have to switch back within that time to see it displayed. There are other climate display menus you can code to ENABLE, like Air Distribution and Show [hvac] Auto Mode. I did not code these to enable, but doubt they will work when the heated button did not work. FWIW.
__________________
Appreciate 0
      10-03-2021, 01:02 PM   #226
1er_vert
Private First Class
45
Rep
195
Posts

Drives: 2010 BMW 128i Cabriolet
Join Date: Dec 2015
Location: Palm Desert, CA USA

iTrader: (0)

Thanks for all this anecdotal experience. I won't be "upgrading" anytime soon. I'll just wait, until the F86 reaches my price point....
__________________
2007 BMW Z4 3.0si - Hellrot
2010 BMW X6 M - Space Grey
Appreciate 1
      01-19-2022, 10:50 AM   #227
Bilbofraggins
Captain
Bilbofraggins's Avatar
Canada
203
Rep
788
Posts

Drives: 2013 X6M, 2019 X3 M40I
Join Date: Feb 2016
Location: North of the Wall

iTrader: (0)

I know as much about the Android side things now as I did when I installed which is now coming up on 2 years.

Does anyone know if we can upgrade to Android 11...from 10?

Still enjoying this upgrade overall.

Last edited by Bilbofraggins; 01-19-2022 at 10:56 AM..
Appreciate 0
      02-06-2022, 12:03 PM   #228
subbu001
Enlisted Member
9
Rep
33
Posts

Drives: BMW X5
Join Date: May 2020
Location: NY

iTrader: (0)

Wow! Just caught up on all the posts. My unit has been working well. Changed phones twice in between and the new phones synced with the unit in the first drive and so far the unit has worked well.

One issue to check with everyone is when I start the unit and my phone connects to the unit, I get the message no GPS or No network on my Waze screen (on the phone and on the android screen). It looks like my phone is looking to the android unit for internet and hence has no data or GPS. As such my Waze location is stuck somewhere and does not register that I have started driving. Sometimes I get the message on my phone asking if the phone should use cellular connection and when I say yes, everything works.
Appreciate 0
      03-10-2022, 11:41 PM   #229
tonyroolze
Registered
0
Rep
3
Posts

Drives: bmw f31
Join Date: Mar 2022
Location: birminham

iTrader: (0)

Quote:
Originally Posted by argento View Post
Updates to the post I restarted on ANDROID MONITOR SOUND...


https://www.bimmerpost.com/forums/sh...php?p=27390678


FINAL: DAC SUMMARY...I considered the following DACS/equipment: FiiO Q5s, FiiO SBR5, Hagibis BT RT TX, Nuprime Hi-mDAC, AudioEngine D1, AudioQuest Dragonfly Red, and Cobalt. The AQ Dragonfly Red or Cobalt, coupled with UAPP, has shown me that we can achieve at least similar audio quality as the OEM side, depending on music source. The OPPO is not an ideal choice because it requires you to manually turn on/off and remove to charge. The FiiO Q5 requires you to manually turn on every time you enter the vehicle, but if you can get past this issue it will provide improved sound quality as well. I did not try the AudioEngine D1 I have on the bench b/c of the success I had with the Dragonfly series DACs. Based on the above results my personal choice is to use the AQ Dragonfly Cobalt with UAPP, OEM Bluetooth for calls, Waze for Navigation, and unlikely use of CarPlay.

So I am in this current position where I want to use CarPlay but wired from my iPhone. I am going to try the Dragonfly red dac connected to the usb of the AA head unit. Currently I understand that Bluetooth is not ideal hence I want to hard wire and use a dac. Do you think this is possible if so how would you think the best connection setup would be.
Appreciate 0
      03-11-2022, 08:41 AM   #230
argento
Captain
argento's Avatar
383
Rep
696
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

If I understand correctly, you want to try to use a DAC to hardwire CarPlay? The DAC will only convert digital audio to analog so it can be played through the cars AUX IN. I think what you want is a CarPlay dongle that connects to the USB of Android Infotainment, see link below...

https://4x4shop.ca/product/all-in-on...oid-head-unit/
__________________
Appreciate 0
      03-13-2022, 08:08 AM   #231
tonyroolze
Registered
0
Rep
3
Posts

Drives: bmw f31
Join Date: Mar 2022
Location: birminham

iTrader: (0)

Quote:
Originally Posted by argento View Post
If I understand correctly, you want to try to use a DAC to hardwire CarPlay? The DAC will only convert digital audio to analog so it can be played through the cars AUX IN. I think what you want is a CarPlay dongle that connects to the USB of Android Infotainment, see link below...

https://4x4shop.ca/product/all-in-on...oid-head-unit/
Sorry for the late reply and thank you for responding. I will give the link you supplied a look 👍
Appreciate 0
      04-09-2022, 03:28 AM   #232
Hanry Manson
Registered
0
Rep
3
Posts

Drives: x6
Join Date: Apr 2022
Location: Miami

iTrader: (0)

Good day you guys.
I need your advice.
I have X6 series E71 2012.
Have been thinking about replacing the original stereo for a long time.
I started looking around on the internet.
Found this company.
https://smarty-trend.com/545-bmw-x5-x6-series-e70-e71
They have a lot of choices, also have information on YouTube.
They specified support for OEM functions, warranty and different ways to buy.
I've never bought one of these before.
I wanted to know what you think about it.
P. S. this is not spam, but a kind request for help, from those people who know about it.
Thank you.
Appreciate 0
      04-10-2022, 09:11 AM   #233
argento
Captain
argento's Avatar
383
Rep
696
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

Quote:
Originally Posted by Hanry Manson View Post
Good day you guys.
I need your advice.
I have X6 series E71 2012.
Have been thinking about replacing the original stereo for a long time.
I started looking around on the internet.
Found this company.
https://smarty-trend.com/545-bmw-x5-x6-series-e70-e71
They have a lot of choices, also have information on YouTube.
They specified support for OEM functions, warranty and different ways to buy.
I've never bought one of these before.
I wanted to know what you think about it.
P. S. this is not spam, but a kind request for help, from those people who know about it.
Thank you.
I could be wrong, but I believe these are all the same units sold by the same or similar manufacturers in China and offered by varying vendors. If you read this long thread (and many others) you'll get a good idea of the strengths and weaknesses. In my experience these are overall a good upgrade b/c you can add some new technology to your E70/E71 platform, the newer versions keep improving sound output, and it's a positive aesthetic improvement IMO. The biggest weakness is that they can feel like beta versions at times with 1) spotty functionality 2) a total immersion into the system is needed to overcome issues 3) random static filled calls, etc. My hope is that each new version continues to overcome these issues and becomes more functional and user friendly.

I will say, as I've mentioned in this thread, I've managed to get better lossless file audio output from this android upgrade via OEM AUX IN versus the OEM side audio (Individual S752A Audio Option). This required the 'total immersion' effort I mention above to figure out. BUT now that I have the capability, to use it requires me EACH time to 1) Wait for android startup 2) clear any screens previously open 3) select Apps 4) select the player 5) discard any window warnings 6) make a few menu selections to get to 'shuffle all'. It doesn't remember the last song I was at when I turned off the car a few minutes ago. [UPDATE: What happens, not sure why, but at the end of a drive I wind up with 2-4 windows of the player app open, though I've only been using one. It just happens in background and I don't notice while in the player app. At the start of the next drive, I can pick one and continue but if I don't clear them out more app windows open in background and then it will get spotty/confused. Maybe it's the app or a setting. Which reminds me, I spent A LOT of time on getting the settings just right]

Whereas if I were on the OEM audio side 1) engine start 2) idrive to external devices (iphone via BT) 3) starts playing from the last song showing in my iphone. I don't use the wireless carplay in the android b/c it skips during playback of music...I believe there is a fix with version updates but upon contacting the vendor I need to reconnect carplay and record a video of the wildly intermittent issue before they'll help me with the update.

$0.02
__________________

Last edited by argento; 04-14-2022 at 08:31 AM..
Appreciate 0
      07-03-2022, 08:25 AM   #234
subbu001
Enlisted Member
9
Rep
33
Posts

Drives: BMW X5
Join Date: May 2020
Location: NY

iTrader: (0)

Network Connection and Bluetooth Gocsdk issues

Hi Everyone - Just sharing 2 things I encountered recently and the solutions that worked for me (after trying a lot of different things!).

1. When the phone connects to the Car Play / android unit it loses its 5G mobile connection as it connects to the android unite via Bluetooth and Wifi Hotspot (i.e. the phone is relying on the android unit to provide it with internet!). This was frustrating as none of the apps in the phone itself like spotify or waze would work anymore since they need an internet connection. After like a 20 mins drive (to sometimes 2hrs or never) a message will pop up on the phone asking if we want to switch to cellular network and then everything works as the phone starts using its 5G connection again. - Final Solution was to delete the android unit wifi profile from the phone wifi settings. It turns out the phone does not need to connect to your android unit via wifi at all.

2. More recently the android unit Bluetooth "GOCSDK" stopped working and stopped appearing when you start the android unit. Since it does not appear in the bluetooth connection window in the android unit, the phone is not able to connect at all. I initially thought it was a wiring issue and tried unscrewing the android unit and pull out the wires check them and re-plug them. This actually worked twice or thrice for like 1 month or so. After that it did not work. Upon further reading in a related blog someone suggested resetting the Bluetooth and network settings and wifi in the android unit. If you go to a similar the android unit settings (outside the carplay environment) under general reset you find the option to reset the network/wifi/bluetooth. Doing this worked for me.
Appreciate 1
argento383.00
      07-03-2022, 09:17 AM   #235
argento
Captain
argento's Avatar
383
Rep
696
Posts

Drives: 2013 X5M
Join Date: Mar 2012
Location: Houston

iTrader: (0)

^Thanks for sharing! Very helpful.

[UPDATE 8July2022 - I've narrowed it down to the UAPP app. I removed and reinstalled and now it's clear that certain song files cause the issue while playing. Stop the song or change the song it goes away. Will contact developer.]

I'll go ahead and post an issue I'm having with no resolution yet: My screen has started to blink and/or resize randomly..

Once it starts it steadily gets worse until it shuts down and I get a recovery message. 4x4 recommended I remove all devices and restart. I've tried that but it returns. It happens during a drive and once I turn off the car for the day it goes away for a while...then returns. It started again this week and this time I turned off the display (upper right square with an X) and continued to listen to the music. Then the music stopped and I got kicked out to the OEM menu. For the next few days I could not get to the Android screen...no amount of touching the screen worked.

I sent 4x4 another video. I then decided to remove the monitor and disconnect the monitor cables and re-connect. I placed the monitor back in place but did not mount. Restarted and waited a few minutes...the oem menu displays and initially nothing happened when I press the screen. I grabbed the monitor to adjust it's position and then it pops to the android screen. Will keep monitoring it...
__________________
Appreciate 0
      07-11-2022, 09:57 PM   #236
TTV8M
Private First Class
United_States
33
Rep
157
Posts

Drives: '10 X6M & '08 Cooper S
Join Date: Feb 2016
Location: NJ 08805

iTrader: (0)

Garage List
2010 BMW X6M  [0.00]
2008 Mini Cooper S  [0.00]
I stumbled across a really nice upgrade for our E70 and E71s

a digital dash cluster

https://id4motion.shop/products/bmw-...igital-cluster

they have a vid in there too so you can see it in action. If you add all the bells and whistles its around $1500 or so, basic version $750. I am considering buying this.
__________________
'10 X6M
'08 Cooper S
Appreciate 0
      07-11-2022, 10:00 PM   #237
TTV8M
Private First Class
United_States
33
Rep
157
Posts

Drives: '10 X6M & '08 Cooper S
Join Date: Feb 2016
Location: NJ 08805

iTrader: (0)

Garage List
2010 BMW X6M  [0.00]
2008 Mini Cooper S  [0.00]
And a retrofit blindspot monitor

https://id4motion.shop/products/bmw-blindspot-monitor

Compatibility
This product is compatible with the following products:

BMW 1 Series E8x Digital Cluster
BMW 3 Series E9x Digital Cluster
BMW 5 Series E6x Digital Cluster
BMW 6 Series E6x Digital Cluster
BMW X5 E70 Digital Cluster
BMW X6 E71 Digital Cluster
BMW Z4 E89 Digital Cluster
__________________
'10 X6M
'08 Cooper S
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:22 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST