XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X5 Forums > General BMW X5 (E70) and X5M Forum (2006-2013)

Post Reply
 
Thread Tools Search this Thread
      09-23-2018, 08:55 PM   #23
chris604
Private
4
Rep
86
Posts

Drives: X5 M
Join Date: Feb 2018
Location: Vancouver, BC, Canada

iTrader: (0)

Quote:
Originally Posted by stephen@velosdesignwerks View Post
Think we have a pretty good product if I don't say so myself
Ok. I'll probably go with Velos then. Some guys are selling a used one online for a good price. But, it says that Velos needs to reprogram it for my specific VIN. How much would that cost?

Thanks for all the suggestions everyone!
Appreciate 0
      09-24-2018, 08:59 AM   #24
carlos@velosdesignwerks
Brigadier General
United_States
376
Rep
4,152
Posts

Drives: BMW M4
Join Date: Jun 2013
Location: Miami

iTrader: (0)

Quote:
Originally Posted by chris604 View Post
Ok. I'll probably go with Velos then. Some guys are selling a used one online for a good price. But, it says that Velos needs to reprogram it for my specific VIN. How much would that cost?

Thanks for all the suggestions everyone!
It would be about $180-$220 euros roughly.
Appreciate 0
      10-04-2018, 12:36 AM   #25
chris604
Private
4
Rep
86
Posts

Drives: X5 M
Join Date: Feb 2018
Location: Vancouver, BC, Canada

iTrader: (0)

Quote:
Originally Posted by stephen@velosdesignwerks View Post
It would be about $180-$220 euros roughly.
Euros, lol? Where would I have to ship it, or can it be done online?
Appreciate 0
      10-04-2018, 08:58 AM   #26
carlos@velosdesignwerks
Brigadier General
United_States
376
Rep
4,152
Posts

Drives: BMW M4
Join Date: Jun 2013
Location: Miami

iTrader: (0)

Quote:
Originally Posted by chris604 View Post
Euros, lol? Where would I have to ship it, or can it be done online?
Give me a call at 7864016520.
Appreciate 0
      11-27-2018, 11:57 AM   #27
burley1
Registered
0
Rep
1
Posts

Drives: 2010 BMW X5M
Join Date: Nov 2017
Location: Weatherford, TX.

iTrader: (0)

After reading this thread, I called and purchased a refurbished unit with 2+. Installed the catless downpipes and flashed the tune. Everything works great and I'm really glad I didn't get an exhaust system. Trucks way louder "in a good way" but the exhaust might have been a bit too much.
Appreciate 0
      11-27-2018, 01:34 PM   #28
9vapors
Captain
357
Rep
865
Posts

Drives: CB X5M
Join Date: Jun 2018
Location: Des Moines

iTrader: (0)

Quote:
Originally Posted by burley1 View Post
After reading this thread, I called and purchased a refurbished unit with 2+. Installed the catless downpipes and flashed the tune. Everything works great and I'm really glad I didn't get an exhaust system. Trucks way louder "in a good way" but the exhaust might have been a bit too much.
Nah, would t be too much... haha. Your neighbors just will hate you. Glad you went with the Velos and glad you're happy with it. I'm in the same boat as you.
Appreciate 0
      11-27-2018, 10:10 PM   #29
cncmastr
Lieutenant Colonel
cncmastr's Avatar
United_States
435
Rep
1,526
Posts

Drives: E30, E46 M3, E53, E39, F31
Join Date: Mar 2006
Location: Toms River, NJ

iTrader: (2)

Garage List
Send a message via AIM to cncmastr
I also bought a Velos tune! I'll post a review once it gets installed!
__________________
Appreciate 0
      11-28-2018, 02:54 PM   #30
funBMWX5M
Registered
2
Rep
4
Posts

Drives: 2010 BMW X5M
Join Date: Sep 2018
Location: Boston

iTrader: (0)

Garage List
2010 BMW X5M  [0.00]
I would be interested in doing this as well. However, I have no idea where to start. The new Velos is steep. Where did you find a used one? Then the next problem is the flashing, etc etc.
Appreciate 0
      11-28-2018, 05:09 PM   #31
mrsoandso
Private
mrsoandso's Avatar
6
Rep
63
Posts

Drives: '11 X6M
Join Date: Feb 2018
Location: On Canada

iTrader: (0)

Anyone have experience with VF engineerings tune? It's well priced, and DDE on youtube is sponsored by them, which I like to support.
Appreciate 0
      11-28-2018, 06:32 PM   #32
9vapors
Captain
357
Rep
865
Posts

Drives: CB X5M
Join Date: Jun 2018
Location: Des Moines

iTrader: (0)

Quote:
Originally Posted by funBMWX5M View Post
I would be interested in doing this as well. However, I have no idea where to start. The new Velos is steep. Where did you find a used one? Then the next problem is the flashing, etc etc.
I would wait or contact them to see if they have some refurbished ones... they are significantly discounted and quite affordable.
Appreciate 1

      11-29-2018, 08:45 AM   #33
carlos@velosdesignwerks
Brigadier General
United_States
376
Rep
4,152
Posts

Drives: BMW M4
Join Date: Jun 2013
Location: Miami

iTrader: (0)

Quote:
Originally Posted by funBMWX5M View Post
I would be interested in doing this as well. However, I have no idea where to start. The new Velos is steep. Where did you find a used one? Then the next problem is the flashing, etc etc.
Hey, can you PM me the price you were quoted please. Let me see if I can help you out in any way.
Appreciate 0
      12-03-2018, 03:52 PM   #34
TempeAndy
New Member
0
Rep
7
Posts

Drives: 2013 X5M
Join Date: May 2018
Location: Tempe, AZ

iTrader: (0)

Just curious if anyone who has had the Velos tune been able to get their vehicle emissions checked? Got the upgrade about a month ago, no CEL or issues -- running great. But pull into Emissions and they can't run the test because the computer says it's not ready. Just wondering if everyone else had to downgrade to stock tune in order to have the OBD emissions test function.
Appreciate 0
      12-28-2018, 09:33 AM   #35
BMW530ia
Enlisted Member
United_States
0
Rep
31
Posts

Drives: 2013 X5M
Join Date: May 2014
Location: Chicago

iTrader: (0)

Just had the emission issue this morning. Put the Velos tune on a few weeks back. I've only driven about 200 miles since then. Went into the emissions test this morning and got a "REJECT" result due to the Catalytic Converter and Heated O2 Sensor coming back as "Not Ready". Everything else came back as "Ready".

They say if the battery was recently disconnected (I replaced mine during the tune process) or vehicle recently repaired the vehicle must complete one or more manufacturer recommended drive cycles. Not sure what BMWs would be.

@TempeAndy - any info you can share if you resolved the problem? Thanks in advance.
__________________
2011 X5 M-Sport (gone)
2008 535ia Sport (gone)
2003 540i M-Sport (gone and missed)
2004 530ia Sport (gone)
Appreciate 0
      12-28-2018, 11:11 AM   #36
TempeAndy
New Member
0
Rep
7
Posts

Drives: 2013 X5M
Join Date: May 2018
Location: Tempe, AZ

iTrader: (0)

Stephen and Omar at Velos said that's the way it's supposed to work. You have to reprogram the ECU back to factory, then drive it 1-2 days, and bring it back to be tested.

Needless to say, I wasn't happy about that news. I did a ton of research before choosing a tune, and never read anywhere about the tune breaking emissions testing.

I suspect Dinan would still be emissions-legal, but then again it's not as powerful a tune. So I guess it's whatever is most important to you?
Appreciate 0
      12-28-2018, 11:16 AM   #37
BMW530ia
Enlisted Member
United_States
0
Rep
31
Posts

Drives: 2013 X5M
Join Date: May 2014
Location: Chicago

iTrader: (0)

Thanks for the reply. Not happy about that news either. I guess I'll put the stock tune back on and see if that gets me to pass. Thanks again for the info.
__________________
2011 X5 M-Sport (gone)
2008 535ia Sport (gone)
2003 540i M-Sport (gone and missed)
2004 530ia Sport (gone)
Appreciate 0
      12-28-2018, 03:10 PM   #38
ncbimma
Private First Class
ncbimma's Avatar
87
Rep
141
Posts

Drives: 2012 BMW X5M
Join Date: Jun 2018
Location: Raleigh, NC

iTrader: (0)

Garage List
This is one of my main reasons I delayed catless DPs. I knew I'd trigger a downstream O2 CEL and all tunes I've inquired will only remove the light from display and leave the sensor in a not ready state.

Only solution is to revert tune and DPs back to stock.

I just got my emissions completed so i have a yr to test out some O2 extenders and O2 mini sensor cats
Appreciate 0
      12-28-2018, 03:53 PM   #39
Molez93
Private First Class
12
Rep
117
Posts

Drives: 2011 X5M, 2006 Z4M
Join Date: Dec 2016
Location: Western NY

iTrader: (0)

Quote:
Originally Posted by BMW530ia View Post
Thanks for the reply. Not happy about that news either. I guess I'll put the stock tune back on and see if that gets me to pass. Thanks again for the info.
Sounds "off" to me.

My 2011 has had a tune almost since it was new. PO never switched tunes back to pass in NY across those 5 years or so. Sure, he might have been lying or recalled the facts wrong, but he was clearly a set it and forget it owner.

Having mentioned that, my prior X5M (2010) tended to throw a CEL pretty quickly with the catless DPs installed and a factory tune.
Appreciate 0
      12-28-2018, 04:09 PM   #40
TempeAndy
New Member
0
Rep
7
Posts

Drives: 2013 X5M
Join Date: May 2018
Location: Tempe, AZ

iTrader: (0)

This is with the factory downpipes and cats installed; only mod on the vehicle is the Velos tune. And no CEL or other signs that the engine isn't running flawlessly.

Evidently -- while the engine runs -- it keeps a history of measurements that are required for the OBD-based emissions test to run. Somehow that history of O2 sensor measurements are missing or disabled.
Appreciate 0
      12-28-2018, 08:15 PM   #41
Molez93
Private First Class
12
Rep
117
Posts

Drives: 2011 X5M, 2006 Z4M
Join Date: Dec 2016
Location: Western NY

iTrader: (0)

Quote:
Originally Posted by TempeAndy View Post
This is with the factory downpipes and cats installed; only mod on the vehicle is the Velos tune. And no CEL or other signs that the engine isn't running flawlessly.

Evidently -- while the engine runs -- it keeps a history of measurements that are required for the OBD-based emissions test to run. Somehow that history of O2 sensor measurements are missing or disabled.
Interesting. Mine ran just ok, and sometimes poorly, when set-up like you described.
Never checked such emissions history.
Appreciate 0
      12-28-2018, 09:57 PM   #42
9vapors
Captain
357
Rep
865
Posts

Drives: CB X5M
Join Date: Jun 2018
Location: Des Moines

iTrader: (0)

Quote:
Originally Posted by TempeAndy View Post
This is with the factory downpipes and cats installed; only mod on the vehicle is the Velos tune. And no CEL or other signs that the engine isn't running flawlessly.

Evidently -- while the engine runs -- it keeps a history of measurements that are required for the OBD-based emissions test to run. Somehow that history of O2 sensor measurements are missing or disabled.
Is it possible Velos sent you their stage 2+ tune?
Appreciate 0
      12-29-2018, 08:29 AM   #43
TempeAndy
New Member
0
Rep
7
Posts

Drives: 2013 X5M
Join Date: May 2018
Location: Tempe, AZ

iTrader: (0)

Quote:
Originally Posted by 9vapors View Post
Is it possible Velos sent you their stage 2+ tune?
I asked them this same question, and they insisted I received the correct tune (i.e. for stock downpipes). Note especially the last sentence regarding ready / not ready state for emissions:

>>
Out policy is for streets cars with stock downpipes to upload your factory tune prior to inspection or service. Not specific to Arizona, California, Europe, or anyone specifically. As far as your specific tune is concerned it is for your vehicle with a stock exhaust setup.
Any other terminology or wording is irrelevant. This is the best way for inspection vehicles because of the range of differences. The “ready” or “not ready” is NOT specific to your exhaust setup
<<
Appreciate 0
      01-02-2019, 11:29 AM   #44
carlos@velosdesignwerks
Brigadier General
United_States
376
Rep
4,152
Posts

Drives: BMW M4
Join Date: Jun 2013
Location: Miami

iTrader: (0)

Hey Andrew,

Was just speaking to the guys here and I know we went back and forth but if you can send a copy of the errors or not ready (we do not show) that we can get to the bottom of it. Had this issue once on a different platform so it may be file specific. Sorry for any delay in communication before. Thanks!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:11 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST