XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      10-20-2018, 06:02 PM   #1
mrsoandso
New Member
mrsoandso's Avatar
2
Rep
16
Posts

Drives: '11 X6M
Join Date: Feb 2018
Location: On Canada

iTrader: (0)

'11 X6M inconsistent ticking + undercoating questions

Hello everyone, I just bought an '11 X6M with 95xxx kilometers (55000 miles).

I have a few questions about the X6 M

I've noticed in drive-thrus that there's a slight ticking sound that randomly comes and goes. It seems to be mostly while warming up. If I pop it in neutral and rev it up a bit, it goes away, but comes back upon idle. Sometimes it doesn't do it at all. Any ideas?

Is undercoating necessary on this vehicle? I live in Canada where the roads are salted, and it seems the previous owner never undercoated it and my rear subframe is getting a little rusty.

Also, is launching really rough on the car? The seemingly knowledgeable bmw parts guy said the M's are only good for a few launches (5-10 launch control starts), then first gear will 'start to wear out'. This seems kind of ridiculous to me. It's a torque converter automatic, the only concern I would have is the center diff which is tq vectoring. Sometimes I feel like 1st gear is a little laggy, or takes a second to engage, and I'm getting a little concerned. I do have extended warranty, but coverage to only $5k.

Sorry for all the questions, this is my first M car and I'm quite overwhelmed with the complexity and cost of ownership thus far. Thanks everyone!

Last edited by mrsoandso; 10-20-2018 at 06:45 PM.
Appreciate 0
      10-23-2018, 12:08 PM   #2
Bilbofraggins
Private
Bilbofraggins's Avatar
Canada
12
Rep
72
Posts

Drives: 2013 X6M, 2015 X3 2.8i
Join Date: Feb 2016
Location: NB, Canada

iTrader: (0)

Hello Mr SoS....I have a 2013 X6M which I have owned since it was a just under 2 years old...bought it with 45K..I now have 97000Km. I now do most of the routine servicing on the M...since Nov 16 (and have a good Indy who steps-up on my vehicles when needed, and just did for some fluid changes). Very easy vehicle to work on if that your thing.

Here are my thoughts...firstly the ticking...if its lifter type tick...never had that on the M...but certainly on an E90...they don't play well with 0W40 type oils here in Canada in the winter...if you do...guess what...Lifter tick....

I doubt that's the problem with the X6M....but I would question the last oil change...was it dealer? If anywhere else they may not be aware that you need 5W30 that is HTHS (High Temp/High Shear)..so for instance Costco is out for you....as their Castrol is 5W30 but is ACEA A1/B1...you need to look on the back label for ACEA A3/B3 or B4 (you can buy it almost anywhere...PM if you want more info on this...there is also a thread. I now use LL04 oil..not LL01.

Undercoating....I had Krown applied a few years ago...but have not bothered since...but funnily enough I'm having drip-less Amber oil applied this afternoon

As for launching...I don't bother with that but do drive spiritedly!! in M mode here and there. I don't track the vehicle...

Your plugs are due at 100,000Km....they will likely be fine...mine where just done...and looked perfect.

As for you tranny...although BMW say life time fill (they don't keep it a lifetime)...ZF who make your tranny say change at 80...to 120,000KM...depending on how its driven...I just did mine and every other fluid...less power steering. You may have seen the comment I shoved up. I did not do the bridge seals or mechatronic seals as I had no problem. So I just dropped the pan and replaced the filter etc. You may need a few seals...all very DIY able...watch a few youtube movies..as there are some suberb ones...

I would also advise booking your vehicle in for the BMW Canada 55 point inspection...that comes with a years BMW NA roadside with accident and other benefits. We do this on 3 x BMW. Last year, on my son's E90 ( a vehicle we have had since new)...they found 7000 bucks worth of work...shocks, brakes, shift shaft seal, blown bulbs etc..we did it for 2k...Vehicle as new now. 60 bucks well spent every year. I trust any recalls are completed?

So some things for you to consider...shoot a message if you think I can be of help. But I would definitely consider the things I recommended.
Between myself...and an 2013 M5 owning friend...also just off warranty...we figure most things out. I can provide some help based on my experiences thus far .. and heavily research based which will save you many hours of BMW/alternatives googling....

Last edited by Bilbofraggins; 10-24-2018 at 12:43 PM.
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:18 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST