XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      01-25-2014, 12:25 AM   #1
mbzkbb
Private First Class
 
Drives: bmw x6m
Join Date: Jun 2013
Location: california

Posts: 108
iTrader: (1)

Brake noise when backing ?

Hello
I had BMW X6M 16000miles now and when backing up brake is making noise .. Only when back up
Dealer replace whole rotor and brake by warranty and after 2-3 month making same noise again ?
And dealer said M model is using performance brake system and sometime making this kind noise ..

But I can't believe it .
Anyone know anything about this ? I really want to fix it . Specially on cold weather at morning or slow backup / braking .. Please let me know anyone know or any shop able to fix it in Southern California .

Thx
mbzkbb is offline  
0
Reply With Quote
      01-25-2014, 05:35 PM   #2
motex
2015 AW/SO M4
 
motex's Avatar
 
Drives: 2015 AW/SO M4
Join Date: Nov 2008
Location: Costa Rica

Posts: 1,128
iTrader: (0)

Garage List
2015 M4  [5.00]
Quote:
Originally Posted by mbzkbb View Post
Hello
I had BMW X6M 16000miles now and when backing up brake is making noise .. Only when back up
Dealer replace whole rotor and brake by warranty and after 2-3 month making same noise again ?
And dealer said M model is using performance brake system and sometime making this kind noise ..

But I can't believe it .
Anyone know anything about this ? I really want to fix it . Specially on cold weather at morning or slow backup / braking .. Please let me know anyone know or any shop able to fix it in Southern California .

Thx
Mine were replaced under warranty (pads only) and noise never returned, maybe they used the same pads on your car instead of the new generation, dont understand why they replaced the rotors since this problem comes from the brake pads (front only)
__________________
....Life is too short to drive boring cars
motex is offline   Costa Rica
0
Reply With Quote
      01-25-2014, 07:05 PM   #3
Roychimac
Private First Class
 
Roychimac's Avatar
 
Drives: X6M
Join Date: Nov 2010
Location: Calgary

Posts: 149
iTrader: (0)

At least you got some new rotors for this!

I believe all performance big brakes make noise, especially when cold, so don't feel like you're the only one. lol
Roychimac is offline   Canada
0
Reply With Quote
      01-25-2014, 09:21 PM   #4
JX5M
Second Lieutenant
 
JX5M's Avatar
 
Drives: 2012 X5M
Join Date: Feb 2011
Location: Illinois

Posts: 200
iTrader: (0)

Definitely not the only one. This Chicago winter has been brutal to say the least and I have only noticed it in my rear brakes recently as well. Not super concerned but I do have the "increased battery drain" as others have commented on... Can't wait to take it to the dealer for that debacle!
JX5M is offline  
0
Reply With Quote
      01-26-2014, 12:50 AM   #5
UAxDEATH(NYC)
Second Lieutenant
 
Drives: BMW X6M 2013
Join Date: Dec 2009
Location: Brooklyn NY

Posts: 259
iTrader: (0)

I bought mine x6m in march 13, even tho in NY is cold as hell, still no noise on mine. Dealer never touched them yet. I'm not the mechanic, but something tells me it has nothing to do with the rotors or pads, it has something to do with axle.
UAxDEATH(NYC) is offline  
0
Reply With Quote
      01-27-2014, 04:25 PM   #6
igorbmwx6
First Lieutenant
 
igorbmwx6's Avatar
 
Drives: 2011 BMW X6M 5.0 xDrive
Join Date: Jan 2012
Location: San Carlos, CA

Posts: 371
iTrader: (0)

Garage List
Send a message via Skype™ to igorbmwx6
Are we talking about high-pitch squeaking noise? If we are, then I hear it on my X6M from front brakes even when car is moving forward. All original brakes, rotors and pads. I have a feeling that the problem is with high-performance brakes on these cars
igorbmwx6 is offline   United_States
0
Reply With Quote
      01-27-2014, 05:00 PM   #7
X5M Badass
Private
 
Drives: BMW X5M
Join Date: Nov 2012
Location: UAE, Dubai

Posts: 75
iTrader: (0)

It's normal...even Ferraris and lambos have this brake noise
X5M Badass is offline   United Arab Emirates
0
Reply With Quote
      01-27-2014, 06:17 PM   #8
mbzkbb
Private First Class
 
Drives: bmw x6m
Join Date: Jun 2013
Location: california

Posts: 108
iTrader: (1)

Thank you for all answer ...

Yes it's Squeaking noise when backing up vehicle. ( mostly in morning or night ((cold weather)) ) .

I know its performance brake system but this is not very little noise . Everyone look me when has noise ...and that feels very bad

in the past always drives AMG never has this kind of noise from brake ...

I Hope anyone know , how to fix it or turn down noise little bit ..

Again thank you for everyone share me all information .

Thank you
mbzkbb is offline  
0
Reply With Quote
      01-28-2014, 11:12 PM   #9
airshaq20
Private
 
Drives: X5M, E60
Join Date: Sep 2013
Location: NoVA

Posts: 85
iTrader: (1)

I have the same issue.
It started when I backed up from my garage - ignored it for a while.
Then it started happening when I drive forward at low speed as well as when backing up.
Had my local dealership look at it, my SA said they were able to replicate it but they could not get BMWNA to replace the system because of low mileage (about 16K miles during that time). I'm now at 17,800 and started to make the noise again. Emailed my SA but told me this is normal because of the "high performance semi-metallic pads".
airshaq20 is offline  
0
Reply With Quote
      01-29-2014, 03:57 AM   #10
mbzkbb
Private First Class
 
Drives: bmw x6m
Join Date: Jun 2013
Location: california

Posts: 108
iTrader: (1)

i think your issue is same with me .

noise was only when i backup on garage and now low speed backup making noise at outside too...

i had around same miles with yours (17k) and dealer replaced pads by warranty as i complainted few times in two month ago...
but, issue didn't fix .... I'm gonna go dealer next week to get fix again. i will give you update.

yes bmw said same thing to me " high performance semi-metallic pads " making noise sometime... (( but, noise is coming everyday now when i backup ))
mbzkbb is offline  
0
Reply With Quote
      01-29-2014, 11:57 AM   #11
isugoo
Major General
 
isugoo's Avatar
 
Drives: 14 M5 CP
Join Date: Feb 2008
Location: Irvine, CA

Posts: 5,705
iTrader: (61)

I had same issue.
1st complain:
SA advised this is common for high performance brake (I had 4 M cars past 10 years and never had this issue).

2nd complain:
Replaced rear brake pads and still noise when backing.

3rd complain:
Replaced front brake pads and no noise... for a while.
Then came back after about 2k miles.

4th complain:
Replaced front pads again and no noise so far (500 miles to date).

I really hope noise doesn't come back since it's annoying and embarrassing. But I know EBC is making low dust/high performance pads (red stuff) so as soon as they release, I will prob. replace oem pads to EBC stuff.
__________________

PAST: 11 E70 X5M | 08 E90 M3 | 08 E92 335i | 03.5 E46 M3 | 99 E36 M3
isugoo is offline   United_States
0
Reply With Quote
      01-29-2014, 12:18 PM   #12
Rob NY
Lieutenant
 
Drives: X5M 550xi
Join Date: Apr 2012
Location: NYC

Posts: 459
iTrader: (3)

I had the same issue at around 15k miles, the dealer changed the pads front and back and its been fine since then close to 10k miles since.
Rob NY is offline  
0
Reply With Quote
      01-31-2014, 05:59 PM   #13
mbzkbb
Private First Class
 
Drives: bmw x6m
Join Date: Jun 2013
Location: california

Posts: 108
iTrader: (1)

Thank you for all information .
I just got fix at dealer again . Took two days and they found intermittent brake squeel noise and cleaned front &rear pads and applied brake paste . Since pad still have 12mm front & rear .

Now no noise anymore at 100miles hope wont have noise again

Thank you
mbzkbb is offline  
0
Reply With Quote
      02-07-2014, 08:23 AM   #14
dhenry
New Member
 
Drives: 2012 X5M
Join Date: Dec 2012
Location: illinois

Posts: 24
iTrader: (0)

Quote:
Originally Posted by JX5M View Post
Definitely not the only one. This Chicago winter has been brutal to say the least and I have only noticed it in my rear brakes recently as well. Not super concerned but I do have the "increased battery drain" as others have commented on... Can't wait to take it to the dealer for that debacle!
i took mine in for the battery drain issue and they checked it and said all was good. since then it has retruned a couple times.
has anyone else dealt with this issue and gotten any results from the dealer?

thanks
dhenry is offline  
0
Reply With Quote
      02-07-2014, 10:33 AM   #15
HPIA4v2
Captain
 
Drives: E60, E71, E92
Join Date: May 2007
Location: Washington

Posts: 671
iTrader: (3)

Can't say for 100% sure, but in my experience it's glazing to pads. You can try hard braking a few times to get rid of that glaze. Sometime, anti-squel paste works, but overtime it dries up.
HPIA4v2 is offline  
0
Reply With Quote
      02-07-2014, 11:28 AM   #16
JX5M
Second Lieutenant
 
JX5M's Avatar
 
Drives: 2012 X5M
Join Date: Feb 2011
Location: Illinois

Posts: 200
iTrader: (0)

Quote:
Originally Posted by dhenry
Quote:
Originally Posted by JX5M View Post
Definitely not the only one. This Chicago winter has been brutal to say the least and I have only noticed it in my rear brakes recently as well. Not super concerned but I do have the "increased battery drain" as others have commented on... Can't wait to take it to the dealer for that debacle!
i took mine in for the battery drain issue and they checked it and said all was good. since then it has retruned a couple times.
has anyone else dealt with this issue and gotten any results from the dealer?

thanks
No I keep putting off going to the dealer because of exactly what happened to you. Bunch of D bags that can't seem to figure this problem out after all these people that have had this same issue over the past 3+ years. I will be going soon and can't wait to argue with the SA.
JX5M is offline  
0
Reply With Quote
      02-08-2014, 04:33 PM   #17
dhenry
New Member
 
Drives: 2012 X5M
Join Date: Dec 2012
Location: illinois

Posts: 24
iTrader: (0)

Quote:
Originally Posted by JX5M View Post
No I keep putting off going to the dealer because of exactly what happened to you. Bunch of D bags that can't seem to figure this problem out after all these people that have had this same issue over the past 3+ years. I will be going soon and can't wait to argue with the SA.
I'm going back too, this is getting crazy. I drove over 2 hours straight yesterday and parked in the garage when i got home and everything was off. Got in today and there it was the message of battery drain.
also, the squeeking of the brakes when i back up is annoying. I guess I never expected this when i bought a very expensive car. Having doubts about another high end BMW.
dhenry is offline  
0
Reply With Quote
      02-09-2014, 07:29 PM   #18
UAxDEATH(NYC)
Second Lieutenant
 
Drives: BMW X6M 2013
Join Date: Dec 2009
Location: Brooklyn NY

Posts: 259
iTrader: (0)

it is sound strange, please keep us updated.
UAxDEATH(NYC) is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:57 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST