XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > X6 Engine / Exhaust / Drivetrain Modification

Post Reply
 
Thread Tools Search this Thread
      03-10-2013, 03:32 PM   #1
S00017064
Registered
 
Drives: x6m
Join Date: Mar 2013
Location: kuwait

Posts: 2
iTrader: (0)

X6m gear and ecu damage

Hi I have a2012 x6m with vorstainer body kit at design down pipes and eisenman race exhaust and ess software update the sad news that the car broke down after 15000 km from installing the ess soft wear . Talked to ess they said The ECU is for sure not damaged in any way. This is simply not possible and you can send it to us for testing and we can verify that it works normally if needed. To damage the transmission is possible with extreme driving and a lot of power, this is user error and abusive driving normally or manufacturing defect/low transmission oil level. Even on stock power it is possible to wear out the stock transmission if driven extremely hard. This is however not a common problem as these transmissions are very strong if used normally. Do not tow heavy loads at full power though.

So I want to ask you guys what might have caused the gear and ecu to get damaged put in mind that I don't race my car , but I do admit to pushing the m bottom everytime Iam in it
S00017064 is offline  
0
Reply With Quote
      03-23-2013, 09:35 PM   #2
330i zhp
Private
 
Drives: X5M and SCd Touring
Join Date: Jan 2011
Location: Washington, DC

Posts: 63
iTrader: (0)

in for answer
330i zhp is offline  
0
Reply With Quote
      05-19-2013, 11:21 PM   #3
TimZ
Lieutenant
 
TimZ's Avatar
 
Drives: X5M
Join Date: May 2010
Location: NYC

Posts: 572
iTrader: (0)

Bump
Any answer? Did you get the problem fixed??
TimZ is offline   Albania
0
Reply With Quote
      05-20-2013, 04:33 AM   #4
titanle
Second Lieutenant
 
Drives: 2010 X6 Activehybrid
Join Date: Jul 2012
Location: vancouver

Posts: 224
iTrader: (0)

in for answer
titanle is offline  
0
Reply With Quote
      05-20-2013, 01:29 PM   #5
northern2020
Lieutenant
 
northern2020's Avatar
 
Drives: '11 X5 M / '01 B5 S4
Join Date: Jan 2011
Location: Alberta

Posts: 501
iTrader: (0)

What's the point of asking for help when you the OP goes mute after asking ?
__________________
| Vorsteiner front splitter | Vorsteiner Vented Hood | Vorsteiner Rear Diffuser | '13 Retrofit LED adaptive Headlamps | Gloss Black Flush Roof Rails | Inside Performance Vent Digital Data Display | ADV-7 22" | ESS | Akra Catless DP's | Akra Evo Exhaust | KW V3 Coilovers| HR TRAK spacers 20mm |
| '11 X5M | '10 Escalade ESV | '12 Audi S4 | '01 Audi S4 |
northern2020 is offline   Canada
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:13 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST