XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      12-15-2012, 10:00 PM   #1
jero20
Enlisted Member
 
Drives: bmw x6
Join Date: Apr 2012
Location: new jersey

Posts: 43
iTrader: (0)

Climate Control

So since I got my car over the summer this have been the first few days that i have needed to use the heat on my car and i noticed something that i consider very odd so wonder if its the same on your X6s

So the issue is that when I set the Temp at 84 (max it goes to) its pretty hot now if i change it by one degree it feels like the air is wayyyyyyyyt colder than 1 degree, feels more like 70s. . .

Have you guys have notice this at all? Is it normal? Something is worht talkng to the dealer for?
jero20 is offline  
0
Reply With Quote
      12-15-2012, 11:35 PM   #2
GreenjellybeanX6
New Member
 
Drives: X6
Join Date: Dec 2012
Location: Seattle

Posts: 15
iTrader: (0)

Yes, I have experienced the same thing. I thought something was wrong with my thermostat. It must be a common issue. Anyone else experience this problem?
GreenjellybeanX6 is offline  
0
Reply With Quote
      12-16-2012, 01:26 AM   #3
ddk632
Major
 
Drives: 2013 BMW X6M
Join Date: Mar 2012
Location: South Florida

Posts: 1,311
iTrader: (0)

Garage List
Either you need 84 or you need ice cold... What's the problem?

Kidding aside, I never had this issue in my X6 35i...
__________________
ddk632 | David Khaykin | (The K is Silent!)
2013 Monte Carlo Blue BMW X6M w/ Mugello Red Interior (E71 LCI)
flickr photos [ Best Of | BMW | Motorcycles & DSLR's ]
ddk632 is offline   United_States
0
Reply With Quote
      12-16-2012, 12:42 PM   #4
mikikuki7
Private First Class
 
Drives: F15 50i
Join Date: Feb 2012
Location: McAllen, TX

Posts: 198
iTrader: (0)

I noticed that because of the caliber of vehicle you have, it's a smart vehicle...

Press the auto button and set the air to whatever degrees you want... On another note, make sure that you check on settings and then air condition and make sure you set it up to how hot you want your air coming front the front vents. Enjoy
mikikuki7 is offline   United_States
0
Reply With Quote
      12-16-2012, 01:58 PM   #5
Mike van D
Major
 
Mike van D's Avatar
 
Drives: SG X6 35i; MW e92 M3
Join Date: Jan 2011
Location: Germany

Posts: 1,114
iTrader: (0)

+1 on checking vent settings as well. There are many hidden climate settings within iDrive that make the system seem a bit squirrelly sometimes.
__________________
...just enjoying life.
Mike van D is offline   Germany
0
Reply With Quote
      12-16-2012, 02:32 PM   #6
doug_999
Captain
 
doug_999's Avatar
 
Drives: 2012 X6 50i/2011 1M
Join Date: Mar 2008
Location: Chicago, IL

Posts: 871
iTrader: (0)

Quote:
Originally Posted by Mike van D View Post
+1 on checking vent settings as well. There are many hidden climate settings within iDrive that make the system seem a bit squirrelly sometimes.
Right, you can have cool air (or hot air) blow from the top vents (for those who like cool air in their face). Mine got set to full cold and nothing I did with the temp would change the vent air until as Mike points out, I went in the iDrive and adjusted the vent setting. I don't remember making any changes to this so I'm not sure how it got messed up.
__________________
2014 650xi GC, Imola Red/Black. MsportEd, CWP, B&O, 20" wheels
2011 1M, Black loaded sans sat radio
doug_999 is offline  
0
Reply With Quote
      12-16-2012, 02:51 PM   #7
Jlam86
Private
 
Drives: 2008 e70 4.8i
Join Date: Jun 2012
Location: Vancouver

Posts: 57
iTrader: (0)

My x5 does the same. Talk to the BMW shop foreman and he said that is normal. When u want heat, it has to be at the maximum temperature (assuming you are not using the auto feature, just simple fan on/off)

I recently keep it in auto and it's great! Set it to the desirable temp and it will ramp the vent up and down according to the intensity in which you want to acquire your desired temperature.
Jlam86 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:50 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST