XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      11-16-2012, 10:09 PM   #1
Kanuc
Private First Class
 
Drives: 2009 X6 50i, 2011 335i xdrive
Join Date: Nov 2009
Location: Calgary

Posts: 158
iTrader: (0)

Power/Torque Loss: PCV Issue? Dinan Stage 2 Issue?

I have a 2009 X6 50 with Dinan Stages 1&2.

I as never super impressed with Dinan Stage 1. It did little to solve the turbo lag problem, whether I drove it in Drive or Sport mode. Manual was fine enough. Anyways, was fun enough on the track.

This summer I had Dinan's Stage 2 installed. Wow, turned a decent monster of a car into an F-22!! Well, not for long. I got a misfiring plug pretty soon after - I was grounded. Replaced all of the plugs. I even asked them to confirm that the Dinan software had neem reinstalled. Here is the TSB for the plugs problem.

TSB Number: SI-B12-22-09 NHTSA Number: 10031664 TSB Date: September 1, 2009

A few weeks later I got a low oil light. The impact of the Dinan software was also gone. Went in for a free quart, which the dealer recorded in their system. Drove for about 3 more weeks and the car called for oil again. This time it stayed with the dealer who diagnosed a PCV valve problem, for which there is also a TSB:

TSB Number: SIB-11-03-08 NHTSA Number: 10038217 TSB Date: December 1, 2010

Dealer said that there was an oil leak as a result of the PCV issue.

Here we are 3 weeks later and again the power/torque is gone. Oil is down one out of three notches on the oil check sensor. I know the power/torque is down because with Stage 2, acceleration is instantaneous and does not require a drop down in the gears in auto modes. When the Dinan 2 is operational, the power is instantly available, even at low RPM. Now the transmission drops down and the power lags.

Anyone else have any ideas, experience, thoughts?
Kanuc is offline   Canada
0
Reply With Quote
      11-21-2012, 12:20 AM   #2
Kanuc
Private First Class
 
Drives: 2009 X6 50i, 2011 335i xdrive
Join Date: Nov 2009
Location: Calgary

Posts: 158
iTrader: (0)

Nobody run into this issue?
Kanuc is offline   Canada
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:16 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST