XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      08-14-2012, 03:43 AM   #1
Dave Xdrive50i
Registered
Kuwait
0

 
Drives: BMW X6 5.0 TT
Join Date: Jul 2012
Location: Kuwait


Posts: 2
iTrader: (0)

Exclamation BMW X6 XDrive50I

hi guys i need some help
my X6 keeps on giving me a reduced power engine malfunction in addition i get Gear box fault when i drive on highway ...

really need some help !
Appreciate 0
      08-14-2012, 12:18 PM   #2
ifly
Cruising!
United_States
2

 
Drives: 2013 X6 50i
Join Date: Jun 2008
Location: Denver


Posts: 109
iTrader: (0)

Sounds like the HPFP, the gearbox could be a programming issue. Would check with dealer for recalls.
Appreciate 0
      09-02-2012, 08:55 AM   #3
foggch
Registered
0

 
Drives: BMW X6 2013 50i
Join Date: Sep 2012
Location: Atlanta


Posts: 1
iTrader: (0)

BMW X6 engine malfunction

Quote:
Originally Posted by Dave Xdrive50i View Post
hi guys i need some help
my X6 keeps on giving me a reduced power engine malfunction in addition i get Gear box fault when i drive on highway ...

really need some help !
This just happened to me last night. I've had the X6 for exactly one week. The first time I drove it on the highway for more then 20 minutes. I had the cruise control on and someone was on my tail trying to pass me. I punched it and the engine malfunction light came on and the car started to shake. Total buzz kill and a bit alarming. I limped to the nearest exit and powered the car down turned it back on and problem was gone. I'm afraid to put my foot on the gas now in a 85k dollar 439 horsepower car. Going up to BMW after the holiday to have it checked out.
Appreciate 0
      09-05-2012, 03:35 PM   #4
Rygel XXV
Private
0

 
Drives: 2009 X6 35i Dinan S2
Join Date: Jun 2011
Location: San Francisco Bay Area


Posts: 74
iTrader: (0)

Quote:
Originally Posted by Dave Xdrive50i View Post
hi guys i need some help
my X6 keeps on giving me a reduced power engine malfunction in addition i get Gear box fault when i drive on highway ...

really need some help !
Quote:
Originally Posted by foggch
This just happened to me last night. I've had the X6 for exactly one week. The first time I drove it on the highway for more then 20 minutes. I had the cruise control on and someone was on my tail trying to pass me. I punched it and the engine malfunction light came on and the car started to shake. Total buzz kill and a bit alarming. I limped to the nearest exit and powered the car down turned it back on and problem was gone. I'm afraid to put my foot on the gas now in a 85k dollar 439 horsepower car. Going up to BMW after the holiday to have it checked out.
Sounds exactly like what happened to me about 6 months ago on a trip to Lake Tahoe, although the problem didn't go away by restarting the car. When I took it to the dealer, they replaced the low pressure fuel pump under warranty. (The HPFP had been previously replaced.)
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:49 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST