XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > X6 Engine / Exhaust / Drivetrain Modification

Post Reply
 
Thread Tools Search this Thread
      06-07-2015, 02:41 PM   #1
SirMedo
Enlisted Member
SirMedo's Avatar
2
Rep
43
Posts

Drives: BMW X6 5.0
Join Date: Jun 2009
Location: Utah

iTrader: (2)

Cylinder 8 Misfire after ESS Tuner Installed

I was hoping to get some help on this issue....

I have installed an ESS Tuner about three months ago. The same day I had a Cylinder 8 Misfire. I read the code and ended up changing out the coil and the spark-plug for Cylinder 8. I did not have any issues up until about a week ago. The same code showed up, Cylinder 8 Misfire. Also...BMW had already replaced all 8 fuel injectors prior to my ESS Tuner.

I have two questions for this... Anybody had this kind of issue and any ideas what it truly could be?

Second question....I was thinking about taking it back to BMW but do I need to re-flash stock setup before the ESS Tuner or can I leave the ESS Tuner setup? Will they be able to tell that it's tuned? I don't want them to find it and void my warranty.

Thanks guys!!
Appreciate 0
      06-09-2015, 01:53 PM   #2
vinhvle
New Member
United_States
1
Rep
14
Posts

Drives: X6M/Trans Am/Matrix
Join Date: Jan 2015
Location: Orlando, FL

iTrader: (0)

Based on the threads I've read about ignition problems with the X Bimmers, spark plugs, ignition coils and fuel injectors are commonly linked to ignition issues and usually need to be replaced in E71s around 40000-50000 miles. I replaced the spark plugs last week in mine, and I'm going to replace the fuel injectors and coils next weekend. Is it possible your spark plug is fouled up because the tune has a richer fuel/air mixture and now the spark plug isn't firing properly?
Appreciate 0
      06-11-2015, 01:53 PM   #3
SirMedo
Enlisted Member
SirMedo's Avatar
2
Rep
43
Posts

Drives: BMW X6 5.0
Join Date: Jun 2009
Location: Utah

iTrader: (2)

I totally agree with you on that.... I flashed it back to stock and it has been running good for now. I am going to take it back and have them look at it. I really appreciate your response.
Thanks again
Appreciate 0
      06-11-2015, 10:43 PM   #4
vinhvle
New Member
United_States
1
Rep
14
Posts

Drives: X6M/Trans Am/Matrix
Join Date: Jan 2015
Location: Orlando, FL

iTrader: (0)

I'm glad I could help out a little bit. In general, fuel injectors are normally upgraded whenever you install power adders so I assumed you'd need to upgrade the fuel or ignition system in the X if you tune it because the gains are so significant. Given the price of new fuel injectors alone, I've been reluctant to get a tune.
Appreciate 0
      06-15-2015, 06:13 AM   #5
Cattivo
FDNY Engine 55
Cattivo's Avatar
United_States
34
Rep
717
Posts

Drives: X5M, X5 50i M Sport
Join Date: Jul 2014
Location: The Concrete Jungle

iTrader: (0)

Quote:
Originally Posted by vinhvle View Post
I'm glad I could help out a little bit. In general, fuel injectors are normally upgraded whenever you install power adders so I assumed you'd need to upgrade the fuel or ignition system in the X if you tune it because the gains are so significant. Given the price of new fuel injectors alone, I've been reluctant to get a tune.
+1
Appreciate 0
      06-17-2015, 12:55 PM   #6
SirMedo
Enlisted Member
SirMedo's Avatar
2
Rep
43
Posts

Drives: BMW X6 5.0
Join Date: Jun 2009
Location: Utah

iTrader: (2)

Quote:
Originally Posted by vinhvle View Post
I'm glad I could help out a little bit. In general, fuel injectors are normally upgraded whenever you install power adders so I assumed you'd need to upgrade the fuel or ignition system in the X if you tune it because the gains are so significant. Given the price of new fuel injectors alone, I've been reluctant to get a tune.

I have not had any issues after flashing it back.... No limp mode or anything. They changed my injectors already a while ago . I guess I wasted the money on the tuner if I cant run it. Ill try the tuner again and see but if ill keep having issues ill just keep it stock.
Thanks again...
Appreciate 0
      07-02-2015, 11:21 AM   #7
SirMedo
Enlisted Member
SirMedo's Avatar
2
Rep
43
Posts

Drives: BMW X6 5.0
Join Date: Jun 2009
Location: Utah

iTrader: (2)

It was a bad coil.... After replacing it no problems for now.
Appreciate 0
      07-02-2015, 06:04 PM   #8
gixxerboy63
X5M Pilot
gixxerboy63's Avatar
United_States
23
Rep
361
Posts

Drives: X5M, M3, GMC Denali
Join Date: Nov 2011
Location: Winston-Salem, NC

iTrader: (2)

good to know... thanks for the follow up.
__________________


X5M Space Gray/Piano Black, Active Autowerks tune, 22" BBS SV Titanium Gunmetal, H&R 1.2 Springs, Weisslicht Halo LEDs, Tint, Black Grills, Black LED Sidemarkers...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:13 AM.




xbimmers
xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST