XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      08-15-2011, 10:47 AM   #1
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

X6m Warning

hey guys.

i have X6M,but i have warning in yellow,sth like this- Engine fault,reduced power,full engine power not longer availible,drive moderately,you can continue journey ,have the problem checked by the nearest BMW Service.

did you experience something like this ?

what do you think i should do?when i turn off the car and then start it it doesnt appear,but only sometimes when i acclerate hard
Appreciate 0
      08-16-2011, 09:04 AM   #2
Dude-
New Member
1

 
Drives: X6M
Join Date: Jan 2011
Location: New York


Posts: 22
iTrader: (0)

Had the same problem as well. I think its because I did a hard acceleration right after start up. Love to know the official explanation if anyone knows.

Thanks.
Appreciate 0
      08-16-2011, 04:51 PM   #3
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

yes it happens after hard acceleration...did you sort the problem out ??what happened?
Appreciate 0
      08-17-2011, 03:39 AM   #4
Deda
Major General
Croatia
74

 
Deda's Avatar
 
Drives: BMW X6 35d
Join Date: Apr 2008
Location: Croatia


Posts: 6,516
iTrader: (0)

Hmmm...any good news from service?
Appreciate 0
      08-17-2011, 09:51 AM   #5
Toronto X6M
New Member
1

 
Drives: 2011 X6M
Join Date: Feb 2011
Location: Toronto


Posts: 10
iTrader: (0)

I got the same message while at the 1/4 mile during 6th or 7th run that day while using launch control. I just idled the car for a while, shut down and restarted and message went away. I assume that the tranny fluid temp got too high and triggered the alarm.
__________________
2009 GTR White: RIP
2011 X6M Monaco Blue
2012 GTR Black Edition White
Appreciate 0
      08-17-2011, 12:43 PM   #6
ChilliWilli
Chillin' like a villain
0

 
ChilliWilli's Avatar
 
Drives: Like i stole it
Join Date: Mar 2009
Location: International member


Posts: 52
iTrader: (0)

Could be first year/generation bugs...a growing number of owners have experienced this. Read further: X5 M Engine Fault Reduced Power Warning
Appreciate 0
      08-17-2011, 05:38 PM   #7
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

i will have my car checked on friday..i read those posts and saw 2 guys couldnt fix the REDUCED POWER fault on their X5M....and they had the car switched to another from BMW after a strugle...one guy later on posted that he also has the fault but that he had it removed after some time and says it was SLOW SOLENOID...dont even know what it is...

here is what he said:

"I am now at 23k miles on my 2010 X5 M, with the reduced power issue appearing occasionally for the past several thousand miles. The vehicle has been in three times to be looked at... and it seems though the issue has finally been resolved. No recurrence over the past 2000 miles. The final fix for me was the replacement of a "slow solenoid". It hasn't been too bad, I had the use of a 7 series from BMW of Dallas for the few days they had it, so no complaints on my part."
Appreciate 0
      08-21-2011, 06:45 AM   #8
it is what is
Registered
0

 
Drives: x6m
Join Date: Aug 2011
Location: cologne


Posts: 2
iTrader: (0)

hey
i read this in a german x6 forum, the guy had the same problem
:

"Der M hat über dem linken und rechten Turbo jeweils einen Luftfilter. Durch diese beiden (überraschender Weise sehr kleinen) Luftfilter saugen die Turbos die benötigte Luft an. Beim kaputten Turbo hatte das kleine Turbinchen an den Flügeln kleine Absplitterungen, die den Fehler wohl verursacht haben und das Teil nicht mehr richtig laufen lies.

Ob es nun Materialermüdung, ein Materialfehler oder Dreck war, der durch den Luftfilter in die Turbine gesaugt wurde, kann man nicht mehr genau sagen.



Die nächsten Wochen werden zeigen, ob der Fehler nun wirklich der Vergangenheit angehört, oder nicht."

translation:
the car has an airfilter above its left and right turbo.through these (surprisingly small) filters, the turbos suck in the required air. One of this turbos has been defect, there was a split-off on the turbine, which caused this defect.they don´t know whether it was a material-defect or just dirt.
the next weeks will show whether this defect is fixed or not."
Appreciate 0
      08-21-2011, 09:30 AM   #9
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

how do you mean the next weeks will show ?did this guy solve the problem ?what is the solution,does BMW know how to fix this problem??
Appreciate 0
      08-22-2011, 03:20 AM   #10
it is what is
Registered
0

 
Drives: x6m
Join Date: Aug 2011
Location: cologne


Posts: 2
iTrader: (0)

yes bmw finally fixed the problem but it took them very long to identify it.
Appreciate 0
      08-22-2011, 04:38 AM   #11
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

so what was the solution to the problem ?i mean its important to know excatly what so others can also fix it,do you think its the same problem for all with this "engine fault reduced power warning"?if its the same problem then we and BMW can save time and fix it fast .thanks
Appreciate 0
      08-22-2011, 04:41 AM   #12
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

i hope you understood me,in your post its not specified what excatly is the problem,was it material defect or dirt that caused the defect on one of the turbos
Appreciate 0
      08-22-2011, 06:12 PM   #13
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

still no answer ?btw do you guys know how to start LAUNCH CONTROL ?
Appreciate 0
      08-22-2011, 06:34 PM   #14
Dude-
New Member
1

 
Drives: X6M
Join Date: Jan 2011
Location: New York


Posts: 22
iTrader: (0)

I'm curious about the engine malfunction results too.

As for the launch control-

Step on break
Place shifter into m1 (that's left and then up)
Turn on M mode
Pedal to the metal
When the flags show up release the breaks.

Keep the pedal to the metal.

Don't forget to smile and put the blinkers on.

Last edited by Dude-; 08-24-2011 at 10:55 AM.
Appreciate 0
      08-23-2011, 08:06 PM   #15
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

all cars with this warning dont have the same problem and same solution ,it can be different things and the car warns ENGINE FAULT REDUCED POWER...am i right??
Appreciate 0
      08-24-2011, 10:59 AM   #16
Dude-
New Member
1

 
Drives: X6M
Join Date: Jan 2011
Location: New York


Posts: 22
iTrader: (0)

edooo, ever since i started warming up the car before ripping it, the malfunction issue went away. The only other thing that was done was putting more oil. My dealer says they drink a lot.
Appreciate 0
      08-25-2011, 07:22 AM   #17
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

i have oil filled and car warmed up and again have this malfunction
Appreciate 0
      09-13-2011, 05:28 PM   #18
edooo
Enlisted Member
2

 
Drives: X6M
Join Date: Jan 2010
Location: europe


Posts: 31
iTrader: (0)

looks like the error is something with turbine,charging pressure...it happend only 2 times after they reseted the erros when i accelerate hard ,and it goes away when i shut down and start again and in service they say everything is fine when they put the car on the tester
Appreciate 0
      09-15-2011, 09:52 AM   #19
Batke
36th Chamber
Canada
3

 
Batke's Avatar
 
Drives: 2011 BMW X6 xDrive50i
Join Date: Jan 2010
Location: Edmonton, Alberta, Canada


Posts: 131
iTrader: (0)

I just had this too. I did rip it from a cold start. I had the "Reduced Power" lite for 1 day. Took it to BMW they had to replace a faulty Turbo Cooler Pump. FYI. Your's might not be that but take her in anyway...
__________________
'11 BMW X6 xDrive 50i (E71) - Space Grey
'08 BMW X3 3.0si (E83) - Alpine White
'04 BMW 745i (E65) - Black Sapphire Metallic
'05 BMW 325i (E46) - Jet Black
'99 Oldsmobile Alero - White
Appreciate 0
      06-16-2012, 01:19 AM   #20
uwinlol
Registered
0

 
Drives: X6M
Join Date: Jun 2012
Location: malaysia


Posts: 4
iTrader: (0)

i have X6M,but i have warning in yellow,sth like this- Engine fault,reduced power,full engine power not longer availible,drive moderately,you can continue journey ,have the problem checked by the nearest BMW Service.
Appreciate 0
      06-16-2012, 01:37 AM   #21
uwinlol
Registered
0

 
Drives: X6M
Join Date: Jun 2012
Location: malaysia


Posts: 4
iTrader: (0)

[quote=edooo;10228482]hey guys.

i have X6M,but i have warning in yellow,sth like this- Engine fault,reduced power,full engine power not longer availible,drive moderately,you can continue journey ,have the problem checked by the nearest BMW Service.

me also having this problems
Appreciate 0
      06-16-2012, 01:47 AM   #22
uwinlol
Registered
0

 
Drives: X6M
Join Date: Jun 2012
Location: malaysia


Posts: 4
iTrader: (0)

why ?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:56 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST