XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      01-14-2010, 01:56 PM   #1
x6er
Private First Class
 
Drives: x6 35i black on black
Join Date: Dec 2009
Location: toronto

Posts: 128
iTrader: (0)

Oil level too high

I have been reading about this all morning...still confused.
I picked up my X6 2 days ago..drove home..checked the idrive and noticed it says "Oil level too high, check with a BMW service centre".
the issue is talked about a lot but no conclusion on reality of the problem or solutions...I will be taking it back to the dealer tomorrow for a check up and I will post the findings.
Comment on your experience with the issue if you had one...cheers
x6er is offline  
0
Reply With Quote
      01-14-2010, 01:59 PM   #2
chuck92103
Major
 
chuck92103's Avatar
 
Drives: 2011 535i
Join Date: May 2008
Location: Socal

Posts: 1,209
iTrader: (0)

Quote:
Originally Posted by x6er View Post
I have been reading about this all morning...still confused.
I picked up my X6 2 days ago..drove home..checked the idrive and noticed it says "Oil level too high, check with a BMW service centre".
the issue is talked about a lot but no conclusion on reality of the problem or solutions...I will be taking it back to the dealer tomorrow for a check up and I will post the findings.
Comment on your experience with the issue if you had one...cheers
I had the same issue.

Dealer replaced an oil level sensor, did not solve issue.

They replaced another oil sensor, still did not resolve issue.

They reloaded iDrive and issue went away.
__________________
2011 535i
2008 VW GTI
chuck92103 is offline  
0
Reply With Quote
      01-14-2010, 06:48 PM   #3
dmlgc
Lieutenant Colonel
 
dmlgc's Avatar
 
Drives: X6M / 335D
Join Date: Jun 2008
Location: Los Gatos, CA

Posts: 1,815
iTrader: (0)

Quote:
Originally Posted by x6er View Post
I have been reading about this all morning...still confused.
I picked up my X6 2 days ago..drove home..checked the idrive and noticed it says "Oil level too high, check with a BMW service centre".
the issue is talked about a lot but no conclusion on reality of the problem or solutions...I will be taking it back to the dealer tomorrow for a check up and I will post the findings.
Comment on your experience with the issue if you had one...cheers
This happened the day I picked up my car. I was sitting in the parking lot going over all the electronics with a product specialist and we came across the oil too high. He had me drive it back to service and had me go into the coffee lounge ( they paid for the latte) about an hour later service manager came out and said they couldn't find anything wrong. He said they had seen this on the 7 series when it first received the dipstickless "improvement" so from experience they drained all the oil and refilled, problem (and warning) went away and has never returned.

I like the electronics but still wish I had a dipstick as a backup.
dmlgc is offline   United_States
0
Reply With Quote
      01-15-2010, 03:26 AM   #4
baloo2
New Member
 
Drives: BMW X6 5.0i / Audi A6 2.7TDI
Join Date: Aug 2009
Location: Slovakia

Posts: 6
iTrader: (0)

I had the same problem at the beginning. Problem dissappeared in 2 days... :-)
baloo2 is offline   Slovakia
0
Reply With Quote
      01-19-2010, 01:36 AM   #5
TheX6M
New Member
 
Drives: X6M 2010 , 1M and now M5 2013
Join Date: Jan 2010
Location: Dubai

Posts: 11
iTrader: (0)

Yes I've experianced the same in my old x6 - 5.0 2009. when checked with the dealer they told me it is a programing issue and it is not real and no problem in driving the car
TheX6M is offline  
0
Reply With Quote
      10-23-2012, 05:09 AM   #6
SmartBastard
Stupid as shit
 
SmartBastard's Avatar
 
Drives: '08 M Coupe
Join Date: Jan 2011
Location: Vienna, Austria

Posts: 364
iTrader: (0)

Had exactly the same problem. After an oil change the car was showing too high level, went back the the garage, they let some oil out and it was still showing full (over max). They refilled the oil back and told me that there's probably some problem with the sensor or the iDrive (they manually checked the oil level and it was sitting right at MAX). After 3 days I went into the menu to check pads (they were also changing them) and the oil level was showing correctly.
SmartBastard is offline   Austria
0
Reply With Quote
      10-23-2012, 05:51 AM   #7
makdeniss
Lord Vader
 
makdeniss's Avatar
 
Drives: BMW X6
Join Date: Mar 2010
Location: Estonia

Posts: 154
iTrader: (0)

Had the same problem. Turned out to be the sensor. This was just after the oil change in BMW dealer.
__________________
My ugly illusions are such a beauty!
makdeniss is offline   Estonia
0
Reply With Quote
      08-23-2013, 12:32 PM   #8
YOLO X6
Registered
 
Drives: BMW X6
Join Date: Oct 2012
Location: Chicago

Posts: 2
iTrader: (0)

Quote:
Originally Posted by x6er View Post
I have been reading about this all morning...still confused.
I picked up my X6 2 days ago..drove home..checked the idrive and noticed it says "Oil level too high, check with a BMW service centre".
the issue is talked about a lot but no conclusion on reality of the problem or solutions...I will be taking it back to the dealer tomorrow for a check up and I will post the findings.
Comment on your experience with the issue if you had one...cheers
Had exactly the same issue with my 2009 X6 50i and dealer came to the conclusion that there must have been moisture over the sensor.
YOLO X6 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:35 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST