XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      01-06-2010, 12:13 PM   #1
SchnellM3
Digger
 
SchnellM3's Avatar
 
Drives: 03 E46 M3, 09 E92 M3, 09 X6 50
Join Date: Jun 2009
Location: Pa

Posts: 2,612
iTrader: (5)

Garage List
Question Trouble with idrive

I have a 09 X6 50i and drive it almost every day, the past few days when I start the car it always asks for the correct time and date due to a battery voltage. It also wont let me play the radio or use the navigation sometimes and doesn't give any reasons. The car sits in a heated garage every night and gets driven 5 out of 7 days a week. Ive had it since late june and cannot imagine its a battery issue. Has anyone else been having this type of problem?
SchnellM3 is offline   United_States
0
Reply With Quote
      01-06-2010, 01:00 PM   #2
BigBobDeuce
Private First Class
 
Drives: 2012 BMW X6M
Join Date: Oct 2009
Location: Georgia

Posts: 109
iTrader: (0)

Garage List
2012 BMW X6M  [0.00]
I just had the exact same issue in my 2009 50i this past weekend. Parked it with valet, and got it back two hours later with no time and date. The trip odometer had been reset, too, but everything else worked fine -- nav & radio presets, seat presets, etc. I blamed it on the cold weather but haven't driven it again to see if the problem has resurfaced.

As another issue, I have the 20-way comfort seats and have noticed that the seat heaters in the front thigh bolster (the one that moves up and back from the seat) only rarely activate. Does anyone else have that problem? I've tried tinkering with Seat Heater Distribution in iDrive to no avail.
BigBobDeuce is offline  
0
Reply With Quote
      01-06-2010, 01:54 PM   #3
Kojak
Private First Class
 
Drives: 535i M-Sport
Join Date: Apr 2008
Location: NC

Posts: 133
iTrader: (0)

try putting a trickle charger on your battery overnight. If the problem then goes away fine. But if it comes back after a while start thinking about a new battery
Kojak is offline   United_States
0
Reply With Quote
      01-06-2010, 03:16 PM   #4
dmlgc
Lieutenant Colonel
 
dmlgc's Avatar
 
Drives: X6 50i/335D
Join Date: Jun 2008
Location: Los Gatos

Posts: 1,803
iTrader: (0)

Quote:
Originally Posted by SchnellM3 View Post
I have a 09 X6 50i and drive it almost every day, the past few days when I start the car it always asks for the correct time and date due to a battery voltage. It also wont let me play the radio or use the navigation sometimes and doesn't give any reasons. The car sits in a heated garage every night and gets driven 5 out of 7 days a week. Ive had it since late june and cannot imagine its a battery issue. Has anyone else been having this type of problem?
Ii would hope that by the 09 model they had resolved putting the wrong battery in but.. these were some of the symptoms owners experience in cars produce just after launch that had the wrong battery in them.
dmlgc is offline   United_States
0
Reply With Quote
      01-06-2010, 03:34 PM   #5
chuck92103
Major
 
chuck92103's Avatar
 
Drives: 2011 535i
Join Date: May 2008
Location: Socal

Posts: 1,209
iTrader: (0)

Newer cars, especially BMW's have so much gadgetry that batteries must be in optimum condition or strange things will occur.
__________________
2011 535i
2008 VW GTI
chuck92103 is offline  
0
Reply With Quote
      01-08-2010, 02:15 AM   #6
archwerks
Captain
 
Drives: x6 3.5i VR
Join Date: Jun 2008
Location: canada

Posts: 683
iTrader: (0)

Have the dealer check the part number of the battery in ur car is the correct one as listed on their service repair/replacement list. Just because it came fr. the factory is no guarantee that it's the right one.
Remember the x6 is "assembled" in the U.S.
Any assumption of Teutonic thoroughness is subject to proof, which have failed in some instances, my vehicle included.
archwerks is offline   Canada
0
Reply With Quote
Post Reply

Bookmarks

Tags
09 x5, 09 x6, 50i, idrive, issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:09 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST