XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X5 Forums > General BMW X5 (E70) and X5M Forum (2006-2013)

Post Reply
 
Thread Tools Search this Thread
      12-30-2012, 04:34 PM   #23
tmling76
New Member
 
Drives: E70
Join Date: Nov 2010
Location: Spain

Posts: 9
iTrader: (0)

Thanks for reply

These are ds1 and I have h7 now for the hids

I think only changing bulbs would nog give better or more light. Think it needs different projectors and that's gonna be a job for a expert what we don't have here around in Spain
tmling76 is offline  
0
Reply With Quote
      03-06-2013, 11:25 PM   #24
Danny1388
New Member
 
Drives: 2011 X5 M
Join Date: Mar 2013
Location: New York

Posts: 11
iTrader: (0)

Maybe battery problem?

I recently got a 2011 x5 m..Does anyone know why my halos/tail lights would not light up when clicking the unlock button on remote? They were working for awhile they suddenly stopped. The welcome light settings are on and lighting is also set on auto...could it be battery problem? it did indicated "low battery" and "increased battery discharge" but went away......feedback please?
Danny1388 is offline  
0
Reply With Quote
      04-15-2013, 09:42 PM   #25
F1Venom
Captain
 
Drives: ZCP E90 M3
Join Date: Apr 2013
Location: USA

Posts: 707
iTrader: (0)

Hello all, I've ordered a pair of LUX H8 Angel Eyes for my dad's X5M to surprise him when he gets back home (his mother just passed away) and I'm expecting the Angel Eyes to arrive tomorrow.
I've looked all over the internet on how to install them into an X5M but all I'm getting is X5 installation procedures. I opened our X5M's hood and the layout of everything looks entirely different from what I've seen and I have no idea where to even start.
Does anybody know of a link or something that gives directions for how to install them? Thanks
F1Venom is offline  
0
Reply With Quote
      04-22-2013, 02:36 PM   #26
JNoSol
Captain
 
JNoSol's Avatar
 
Drives: F06 and E70-Sport
Join Date: Feb 2012
Location: Kansas City

Posts: 900
iTrader: (0)

loe9066: I installed the mTEC V2 on my friend's E90 and my F02. I got them for $220shipped from mTEC Lighting USA. It's very bright and the light produced fills all rings. My review below.

http://www.7post.com/forums/showthread.php?t=831034
JNoSol is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:15 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST