XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X5 Forums > General BMW X5 (E70) and X5M Forum (2006-2013)

Post Reply
 
Thread Tools Search this Thread
      12-10-2016, 10:16 PM   #1
borderm3
New Member
5
Rep
21
Posts

Drives: E70 X5 M Sport
Join Date: Apr 2013
Location: FL

iTrader: (0)

Notification That Trailer Brake Lights are Not Working

When I hook my trailer up, I get a notification asking me to check the brake lights on the trailer. I did, they seem to be working fine. I tried unplugging and replugging the trailer wiring harness.

Any thoughts?
Appreciate 0
      12-10-2016, 10:33 PM   #2
s65m3fan
Private
s65m3fan's Avatar
United_States
8
Rep
66
Posts

Drives: 2013 BMW M3, 2013 X5 35d
Join Date: Dec 2013
Location: United States

iTrader: (1)

If the trailer lights are LED, that's most likely what's causing the issue. Sometimes mine indicates my left trailer bulb needs to be checked the first time I start my X5 with the trailer connected. The notification clears and the brake lights always work.
__________________
2013 Jerez Black E92 M3 DCT ZCP | PFC Z54/Z45 BBK | MCS 2-way Remote Dampers | Hypercoil 600/900lb Springs | Ground Control Race Camber Plates | Bimmerworld Control Arm Bearings | Powerflex Sway Bar Bushings and Shock Mounts | EDC Delete | Macht Schnell Stage 2 Intake | Akrapovic Exhaust | Bimmerworld Race Studs | CSF Radiator | CSF Oil Cooler | Bimmerworld Power Steering Reservoir | Euro MDM | Lux H8 160 | BMW CF Front Splitters | BMW CF Competition Rear Spoiler | Schroth Quick Fit Pro | HRE R43
Appreciate 0
      12-10-2016, 11:01 PM   #3
borderm3
New Member
5
Rep
21
Posts

Drives: E70 X5 M Sport
Join Date: Apr 2013
Location: FL

iTrader: (0)

Interesting. I haven't drove it but more than 10 minutes or so. It did not clear in this time, at least that I noticed.. All the lights are tungsten wire, except perhaps the two brake lights, they are bar shaped, they might be led.

I guess that makes sense if they are on a discrete circuit to be illuminated when the brakes are pressed. Maybe I can add a resistor in line to mimic the resistance of tungsten wire?

Chris
Appreciate 0
      12-18-2016, 02:09 PM   #4
borderm3
New Member
5
Rep
21
Posts

Drives: E70 X5 M Sport
Join Date: Apr 2013
Location: FL

iTrader: (0)

Turns out in my case, this was from not having the trailer module programmed properly.
Appreciate 0
      06-20-2017, 07:27 AM   #5
Cruisin_Newfie
Registered
Canada
0
Rep
3
Posts

Drives: 2013 X5 35i
Join Date: Dec 2016
Location: Nova Scotia

iTrader: (0)

Trailer Programming

Quote:
Originally Posted by borderm3 View Post
Turns out in my case, this was from not having the trailer module programmed properly.
Where did you find info on how to program the trailer module? I have found lots of people talking about it but no step-by-step instructions on how to do it!
Appreciate 0
      11-10-2017, 02:38 PM   #6
adriang
******
adriang's Avatar
Canada
19
Rep
679
Posts

Drives: 2011 BMW 335d
Join Date: Feb 2012
Location: Niagara Region, Toronto, The Boonies

iTrader: (0)

Interested in a response on this one too! My have to get the coding looked at again like in borderm3's case

similar situation for me, however brake lights never worked all other lights worked.

Last edited by adriang; 12-03-2017 at 09:01 PM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:14 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST