XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X5 Forums > General BMW X5 (E70) and X5M Forum (2006-2013)

Post Reply
 
Thread Tools Search this Thread
      04-26-2017, 12:43 AM   #1
xtahoex
New Member
0
Rep
7
Posts

Drives: 2010 X5 M Alpine White
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Parking Brake EMF Issue

I bought my x5m back in January of this year. A week after owning it the parking brake went out. I had to manually release the brake. I tried a reset procedure with no luck. I ended up purchasing a refurbished parking brake from eBay and installing it. Once it was installed I used NCS expert to code the new brake to the vehicle order. I again tried using the push and pull method on the parking brake button to initialize the brake. The brake is not responding at all. I am beginning to think that the new parking brake is not working. Does anyone have any experience installing a new parking brake on to an e70? I have heard conflicting information about removing the negative battery terminal before hooking up the wiring to the new brake. Does anyone know? I read the procedure in ISTA and it appears that there is some sort of device that BMW uses to deal with power yo the module during the removal and installation of a new parking brake. If anyone knows can you please chime in.

Thank you.
Ryan
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:23 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST