XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > X6 Engine / Exhaust / Drivetrain Modification

Post Reply
 
Thread Tools Search this Thread
      03-24-2010, 05:38 PM   #1
scottyv
Modding Master
 
Drives: 2010 X6 5.0
Join Date: Oct 2009
Location: Michigan

Posts: 80
iTrader: (0)

X6 burning oil

My 2010 X6 5.0 seems to be using oil a little more than I feel is normal.

At about 4100 miles my engine monitor notified me I needed oil and I added a quart.

Now at 5200 my oil guage shows me down about a quarter of a quart which works out to about a quart per 4000 miles.

This seems strange to me as I have never owned a vehicle that really used any oil (my normal changes were at 7500 mi max).

Anyone else have a vehicle using oil at this rate, or any ideas as to the cause or is it not that unordinary with a performance engine like the TT V-8?

I will say I am a heavy footed driver too !

Any opinions would much appreciated here
__________________
2010 Alpine White X6 5.0 with Oyster Leather / Dark Wood Trim -- Sport Package with 20" Style 259 Wheels, Premium Pkg, Premium Sound, 7RR Performance Pkg, Active Steering, Running Boards, Rear View Cam & Top view, Cold Weather Pkg, Rear Climate Pkg, Comfort Access, Space Saver Spare, Sat Radio, Smartphone Integration
scottyv is offline   United_States
0
Reply With Quote
      03-24-2010, 05:44 PM   #2
scottyv
Modding Master
 
Drives: 2010 X6 5.0
Join Date: Oct 2009
Location: Michigan

Posts: 80
iTrader: (0)

Ok, I did a forum search and I guess I have nop worries as others have used oil expecially during the early/breakin miles.
__________________
2010 Alpine White X6 5.0 with Oyster Leather / Dark Wood Trim -- Sport Package with 20" Style 259 Wheels, Premium Pkg, Premium Sound, 7RR Performance Pkg, Active Steering, Running Boards, Rear View Cam & Top view, Cold Weather Pkg, Rear Climate Pkg, Comfort Access, Space Saver Spare, Sat Radio, Smartphone Integration
scottyv is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:49 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST