XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      05-01-2009, 06:30 PM   #1
Roger_Calabasas
Registered
 
Drives: 2009 X6
Join Date: May 2009
Location: Calabasas, CA

Posts: 1
iTrader: (0)

Question G3 iPhone Compatibility with My 2009 X6

Just got my 2009 X6. Fun to drive, but not so fun to use. :-( Big regressions in iDrive as compared to the 2006 7-series I just gave up - and other issues that are just a bummer. But here's my big one: When I am on a phone call on my G3 iPhone handset and get into my car and turn the car on, instead of going onto the phone's speaker system immediately (as my 2006 7-series used to do perfectly!), it cuts off the audio completely. It doesn't go onto the speaker system AND it cuts off the handset, as well. (At the same time, it takes literally 2 minutes to download my phone book - and I only have 20 phone numbers in my phone book!!) The dealer tells me that the G3 iPhone is not supported and it's my own problem, but then why did it work so perfectly with my 3-year-old 7-series?!? Would be grateful for any solution/workaround anyone can offer me. Thanks!
Roger_Calabasas is offline  
0
Reply With Quote
      05-01-2009, 06:53 PM   #2
JeepJeep
ಠ_ಠ
 
JeepJeep's Avatar
 
Drives: everywhere
Join Date: Mar 2009
Location: 818 / 805

Posts: 1,959
iTrader: (0)

Im assuming you've looked through the manual and appropriate iDrive menus to see if its just the way the car is set-up?

I know that the iPhone has had many problems with connection - I saw a test where two identical iPhones next to each other were getting different levels of reception - so this could just be it.

Sorry it doesn't work, do you think maybe theres an update that you might not have gotten?
__________________
JeepJeep is offline   United_States
0
Reply With Quote
      05-01-2009, 09:20 PM   #3
G5Ti
Purveyor of fine roads.
 
G5Ti's Avatar
 
Drives: 2008 BMW 128i
Join Date: Mar 2008
Location: Ohio

Posts: 339
iTrader: (0)

Not sure as to workarounds, but the BMW bluetooth works fine with the two original iPhones and two iPhone 3Gs in our household. Audio works as it did for your 7-series... the phonebook is a bit slow to download, but only on the first pairing.

Perhaps it's an iDrive thing?
__________________
128i alpine | coral | premium | sport | cold | xenons | ipod+usb
G5Ti is offline   United_States
0
Reply With Quote
      05-03-2009, 07:25 PM   #4
dmlgc
Lieutenant Colonel
 
dmlgc's Avatar
 
Drives: X6 50i/335D
Join Date: Jun 2008
Location: Los Gatos

Posts: 1,803
iTrader: (0)

I have 2g iphone and don't see the problem, usually switches to in car before I sit down. This is just pure iphone no headset/earbud ?


update: now have 3gs iphone works ok.

Last edited by dmlgc; 08-25-2009 at 11:47 AM.
dmlgc is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Tags
bluetooth, iphone, phone

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:40 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST