XBimmers.com | BMW X6 Forum X5 Forum
 
TireRack





Go Back   XBimmers.com | BMW X6 Forum X5 Forum > BMW X6 Forums > General BMW X6 and X6M Forum

Post Reply
 
Thread Tools Search this Thread
      03-03-2011, 12:31 PM   #1
roentgen72
Private
 
Drives: 2011 X6M
Join Date: Sep 2010
Location: richmond hill

Posts: 57
iTrader: (0)

Idrive controller does not work

ANy body have any issues with idrive controller not operating. The screen seems fine, just doesn't accept input from controller ie the controller turns and buttons depress, but it does not register on screen. Also the backlit lights are off. Could the fuse be blown or do I need a trip to the dealer?
roentgen72 is offline   Canada
0
Reply With Quote
      03-03-2011, 09:57 PM   #2
newdadkel
Private First Class
 
newdadkel's Avatar
 
Drives: 2011 X6M CBM
Join Date: Nov 2010
Location: Texas

Posts: 190
iTrader: (0)

Recommend seeing dealer. IF 2008, you should be under warranty anyway.
newdadkel is offline   United_States
0
Reply With Quote
      02-05-2013, 12:20 PM   #3
lowell_b
Enlisted Member
 
lowell_b's Avatar
 
Drives: 2007 E70 X5
Join Date: Mar 2011
Location: New Jersey

Posts: 45
iTrader: (0)

Quote:
Originally Posted by roentgen72 View Post
ANy body have any issues with idrive controller not operating. The screen seems fine, just doesn't accept input from controller ie the controller turns and buttons depress, but it does not register on screen. Also the backlit lights are off. Could the fuse be blown or do I need a trip to the dealer?
I have the same issue with my iDrive too. Sometimes it works but majority of the time it doesn't. Finally it worked last week and i was able to reset pretty much everything. I'm looking into replacing a fuse or maybe even trying to open up the idrive n clean out the area. Possibly coffee or juice might have gotten in it but that's just my guess. I'm out of my warranty too and sucks this issue happened 1 month after my warranty ended. lol
__________________
Laughter is the BEST medicine.
lowell_b is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:20 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST